fstools: Add the new options available in the menuconfig
authorPierre Lebleu <pme.lebleu@gmail.com>
Thu, 24 May 2018 12:20:33 +0000 (14:20 +0200)
committerJohn Crispin <john@phrozen.org>
Thu, 24 May 2018 14:05:07 +0000 (16:05 +0200)
Mounting using the zlib compression and mounting with
full access accounting are now available in the
menuconfig.

Signed-off-by: Pierre Lebleu <pme.lebleu@gmail.com>
package/system/fstools/Makefile

index 494f90d2e68b788cc96e68ee9618224cc1b29650..ad5197af4b54028b28cdd0e6bb0a8ec94192f1b7 100644 (file)
@@ -33,6 +33,8 @@ include $(INCLUDE_DIR)/cmake.mk
 
 TARGET_LDFLAGS += $(if $(CONFIG_USE_GLIBC),-lrt)
 CMAKE_OPTIONS += $(if $(CONFIG_FSTOOLS_UBIFS_EXTROOT),-DCMAKE_UBIFS_EXTROOT=y)
+CMAKE_OPTIONS += $(if $(CONFIG_FSTOOLS_OVL_MOUNT_FULL_ACCESS_TIME),-DCMAKE_OVL_MOUNT_FULL_ACCESS_TIME=y)
+CMAKE_OPTIONS += $(if $(CONFIG_FSTOOLS_OVL_MOUNT_COMPRESS_ZLIB),-DCMAKE_OVL_MOUNT_COMPRESS_ZLIB=y)
 
 define Package/fstools
   SECTION:=base
@@ -50,6 +52,20 @@ define Package/fstools/config
                default y
                help
                        This option makes it possible to use extroot functionality if the root filesystem resides on an UBIFS partition
+
+       config FSTOOLS_OVL_MOUNT_FULL_ACCESS_TIME
+               depends on PACKAGE_fstools
+               bool "Full access time accounting"
+               default n
+               help
+                       This option enables the full access time accounting (warning: it will increase the flash writes).
+
+       config FSTOOLS_OVL_MOUNT_COMPRESS_ZLIB
+               depends on PACKAGE_fstools
+               bool "Compress using zlib"
+               default n
+               help
+                       This option enables the compression using zlib on the storage device.
 endef
 
 define Package/snapshot-tool