include: autotools.mk: do not fail in patch-libtool fixup if patch is already applied
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 11 Oct 2011 18:15:12 +0000 (18:15 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 11 Oct 2011 18:15:12 +0000 (18:15 +0000)
SVN-Revision: 28419

include/autotools.mk

index 1472b5a..1ce25bc 100644 (file)
@@ -56,7 +56,7 @@ define patch_libtool
                        lt_version="$$$$($$(STAGING_DIR_HOST)/bin/sed -ne 's,^[[:space:]]*VERSION=\([0-9]\.[0-9]\+\).*,\1,p' $$$$lt)"; \
                        case "$$$$lt_version" in \
                                1.5|2.2|2.4) echo "autotools.mk: Found libtool v$$$$lt_version - applying patch to $$$$lt"; \
-                                       (cd $$$$(dirname $$$$lt) && $$(PATCH) -s -p1 < $$(TOPDIR)/tools/libtool/files/libtool-v$$$$lt_version.patch) ;; \
+                                       (cd $$$$(dirname $$$$lt) && $$(PATCH) -N -s -p1 < $$(TOPDIR)/tools/libtool/files/libtool-v$$$$lt_version.patch || true) ;; \
                                *) echo "autotools.mk: error: Unsupported libtool version v$$$$lt_version - cannot patch $$$$lt"; exit 1 ;; \
                        esac; \
                done; \