Remove pcmcia support from ssb.
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 24 May 2009 11:30:06 +0000 (11:30 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 24 May 2009 11:30:06 +0000 (11:30 +0000)
SVN-Revision: 16023

package/kernel/modules/other.mk
target/linux/generic-2.6/patches-2.6.27/974-ssb_b43_default_on.patch
target/linux/generic-2.6/patches-2.6.28/974-ssb_b43_default_on.patch

index 392a88ed0fa8de770039c207f91c3afc93013747..8e51e1abf68d2671357daf231f3b71f52406da5e 100644 (file)
@@ -121,7 +121,6 @@ endef
 
 $(eval $(call KernelPackage,pcspkr))
 
-# This activates PCMCIA support in ssb. This will be included in kmod-ssb.
 define KernelPackage/pcmcia-core
   SUBMENU:=$(OTHER_MENU)
   TITLE:=PCMCIA/CardBus support
@@ -132,9 +131,6 @@ define KernelPackage/pcmcia-core
        CONFIG_PCCARD \
        CONFIG_YENTA \
        CONFIG_PCCARD_NONSTATIC \
-       CONFIG_SSB_PCMCIAHOST=y \
-       CONFIG_SSB_PCMCIAHOST_POSSIBLE=y \
-       CONFIG_SSB_BLOCKIO=y \
        PCMCIA_DEBUG=n
 endef
 
index a5e84ba57e3c95f2f07cd9bdfd3fdb3285abe8ea..943230f761992ae0463656d5e8ea7e0f1ca2ad72 100644 (file)
@@ -1,14 +1,5 @@
 --- a/drivers/ssb/Kconfig
 +++ b/drivers/ssb/Kconfig
-@@ -26,7 +26,7 @@ config SSB_SPROM
- # Support for Block-I/O. SELECT this from the driver that needs it.
- config SSB_BLOCKIO
--      bool
-+      bool "add SSB_BLOCKIO support"
-       depends on SSB
- config SSB_PCIHOST_POSSIBLE
 @@ -48,7 +48,7 @@ config SSB_PCIHOST
  config SSB_B43_PCI_BRIDGE
        bool
index 8a00df581bc34fb029a11fdf041d58957b1d8950..98dde2a3c8b34837443cda706165adf4a8fc97f7 100644 (file)
@@ -1,14 +1,5 @@
 --- a/drivers/ssb/Kconfig
 +++ b/drivers/ssb/Kconfig
-@@ -27,7 +27,7 @@ config SSB_SPROM
- # Support for Block-I/O. SELECT this from the driver that needs it.
- config SSB_BLOCKIO
--      bool
-+      bool "add SSB_BLOCKIO support"
-       depends on SSB
- config SSB_PCIHOST_POSSIBLE
 @@ -49,7 +49,7 @@ config SSB_PCIHOST
  config SSB_B43_PCI_BRIDGE
        bool