image: allow specifying additional packages for device-specific rootfs
authorMatthias Schiffer <mschiffer@universe-factory.net>
Sat, 24 Sep 2016 16:25:25 +0000 (18:25 +0200)
committerMatthias Schiffer <mschiffer@universe-factory.net>
Sat, 24 Sep 2016 16:25:25 +0000 (18:25 +0200)
Add a new option to each device in multi-profile mode, allowing to provide
a list of packages to add or remove. In case of added packages, the user
must take care that these are selected to be built.

Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
include/image.mk
scripts/target-metadata.pl

index 63cefff05c4ef8a187429338619e4c94b407a12f..3085400666f9d6793fda603d98716252d028d4a5 100644 (file)
@@ -387,11 +387,21 @@ else
   DEVICE_CHECK_PROFILE = $(CONFIG_TARGET_$(if $(CONFIG_TARGET_MULTI_PROFILE),DEVICE_)$(call target_conf,$(BOARD)$(if $(SUBTARGET),_$(SUBTARGET)))_$(1))
 endif
 
+DEVICE_EXTRA_PACKAGES = $(call qstrip,$(CONFIG_TARGET_DEVICE_PACKAGES_$(call target_conf,$(BOARD)$(if $(SUBTARGET),_$(SUBTARGET)))_DEVICE_$(1)))
+
+define merge_packages
+  $(1) :=
+  $(foreach pkg,$(2),
+    $(1) := $$(strip $$(filter-out -$$(patsubst -%,%,$(pkg)) $$(patsubst -%,%,$(pkg)),$$($(1))) $(pkg))
+  )
+endef
+
 define Device/Check/Common
   _PROFILE_SET = $$(strip $$(foreach profile,$$(PROFILES) DEVICE_$(1),$$(call DEVICE_CHECK_PROFILE,$$(profile))))
   ifdef TARGET_PER_DEVICE_ROOTFS
-    ROOTFS_ID/$(1) := $$(if $$(_PROFILE_SET),$$(call mkfs_packages_id,$$(DEVICE_PACKAGES)))
-    PACKAGES_$$(ROOTFS_ID/$(1)) := $$(DEVICE_PACKAGES)
+    $$(eval $$(call merge_packages,_PACKAGES,$$(DEVICE_PACKAGES) $$(call DEVICE_EXTRA_PACKAGES,$(1))))
+    ROOTFS_ID/$(1) := $$(if $$(_PROFILE_SET),$$(call mkfs_packages_id,$$(_PACKAGES)))
+    PACKAGES_$$(ROOTFS_ID/$(1)) := $$(_PACKAGES)
   endif
 endef
 
index a7239166f7b1ffb5d411bafeedc0b79d33d1373d..07160dc4ea2c890886a2401a0ba1b597b0337afb 100755 (executable)
@@ -263,7 +263,7 @@ EOF
                foreach my $profile (@{$target->{profiles}}) {
                        next unless $profile->{id} =~ /^DEVICE_/;
                        print <<EOF;
-config TARGET_DEVICE_$target->{conf}_$profile->{id}
+menuconfig TARGET_DEVICE_$target->{conf}_$profile->{id}
        bool "$profile->{name}"
        depends on TARGET_$target->{conf}
        default y if TARGET_ALL_PROFILES
@@ -274,6 +274,17 @@ EOF
                                print "\tselect MODULE_DEFAULT_$pkg if TARGET_PER_DEVICE_ROOTFS\n";
                                $defaults{$pkg} = 1;
                        }
+
+                       print <<EOF;
+
+
+       config TARGET_DEVICE_PACKAGES_$target->{conf}_$profile->{id}
+               string "$profile->{name} additional packages"
+               default ""
+               depends on TARGET_PER_DEVICE_ROOTFS
+               depends on TARGET_DEVICE_$target->{conf}_$profile->{id}
+
+EOF
                }
        }