ipq40xx: 5.10: refresh patches to apply
authorRobert Marko <robert.marko@sartura.hr>
Sun, 12 Sep 2021 20:36:12 +0000 (22:36 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sat, 25 Sep 2021 17:28:54 +0000 (19:28 +0200)
Refresh the kernel patches on top of 5.10 so they apply.
Manually fixup the 705-net-add-qualcomm-ar40xx-phy.patch
to apply.

Signed-off-by: Robert Marko <robert.marko@sartura.hr>
target/linux/ipq40xx/patches-5.10/301-arm-compressed-add-appended-DTB-section.patch
target/linux/ipq40xx/patches-5.10/302-arm-compressed-set-ipq40xx-watchdog-to-allow-boot.patch
target/linux/ipq40xx/patches-5.10/400-mmc-sdhci-sdhci-msm-use-sdhci_set_clock-instead-of-s.patch
target/linux/ipq40xx/patches-5.10/703-net-IPQ4019-needs-rfs-vlan_tag-callbacks-in.patch
target/linux/ipq40xx/patches-5.10/705-net-add-qualcomm-ar40xx-phy.patch
target/linux/ipq40xx/patches-5.10/707-net-phy-Add-Qualcom-QCA807x-driver.patch
target/linux/ipq40xx/patches-5.10/850-soc-add-qualcomm-syscon.patch
target/linux/ipq40xx/patches-5.10/901-arm-boot-add-dts-files.patch
target/linux/ipq40xx/patches-5.10/997-device_tree_cmdline.patch

index 7e6184fc7321ced88d9017df0bd20d1dcfb99b71..99e33632c4ce9aaab727f836d95d2042b6823b2a 100644 (file)
@@ -26,7 +26,7 @@ Signed-off-by: Robert Marko <robimarko@gmail.com>
 
 --- a/arch/arm/boot/compressed/vmlinux.lds.S
 +++ b/arch/arm/boot/compressed/vmlinux.lds.S
-@@ -93,6 +93,13 @@ SECTIONS
+@@ -101,6 +101,13 @@ SECTIONS
  
    _edata = .;
  
@@ -40,9 +40,9 @@ Signed-off-by: Robert Marko <robimarko@gmail.com>
    /*
     * The image_end section appears after any additional loadable sections
     * that the linker may decide to insert in the binary image.  Having
-@@ -132,4 +139,4 @@ SECTIONS
-   .stab.indexstr 0    : { *(.stab.indexstr) }
-   .comment 0          : { *(.comment) }
+@@ -138,4 +145,4 @@ SECTIONS
+   ARM_ASSERTS
  }
 -ASSERT(_edata_real == _edata, "error: zImage file size is incorrect");
 +ASSERT(_edata_real == _edata_dtb, "error: zImage file size is incorrect");
index 71618a40f2a0b5b10e4a108256176518fdeba295..b2239d82dcfd93c4ef39403b3c9d4a9031ea03c9 100644 (file)
@@ -22,7 +22,7 @@ Signed-off-by: John Thomson <git@johnthomson.fastmail.com.au>
 
 --- a/arch/arm/boot/compressed/head.S
 +++ b/arch/arm/boot/compressed/head.S
-@@ -599,6 +599,41 @@ not_relocated:    mov     r0, #0
+@@ -601,6 +601,41 @@ not_relocated:    mov     r0, #0
                bic     r4, r4, #1
                blne    cache_on
  
index e56ab6d0f1c2380f8f8ec63382de32d0a03370e0..fd46d54916a55618115a38700ceb387f0af15a7b 100644 (file)
@@ -1,23 +1,22 @@
-From 0e28623a11f3916c1fe5b7e789c7ab8ca932a929 Mon Sep 17 00:00:00 2001
-From: Robert Marko <robimarko@gmail.com>
-Date: Wed, 22 Jan 2020 13:02:13 +0100
-Subject: [PATCH] mmc: sdhci: sdhci-msm: use sdhci_set_clock instead of
- sdhci_msm_set_clock
+From f63ea127643a605da97090ce585fdd7c2d17fa42 Mon Sep 17 00:00:00 2001
+From: Robert Marko <robert.marko@sartura.hr>
+Date: Mon, 14 Dec 2020 13:35:35 +0100
+Subject: [PATCH] mmc: sdhci-msm: use sdhci_set_clock
 
 When using sdhci_msm_set_clock clock setting will fail, so lets
 use the generic sdhci_set_clock.
 
-Signed-off-by: Robert Marko <robimarko@gmail.com>
+Signed-off-by: Robert Marko <robert.marko@sartura.hr>
 ---
  drivers/mmc/host/sdhci-msm.c | 2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)
 
 --- a/drivers/mmc/host/sdhci-msm.c
 +++ b/drivers/mmc/host/sdhci-msm.c
-@@ -1746,7 +1746,7 @@ MODULE_DEVICE_TABLE(of, sdhci_msm_dt_mat
+@@ -2191,7 +2191,7 @@ MODULE_DEVICE_TABLE(of, sdhci_msm_dt_mat
  
  static const struct sdhci_ops sdhci_msm_ops = {
-       .reset = sdhci_reset,
+       .reset = sdhci_msm_reset,
 -      .set_clock = sdhci_msm_set_clock,
 +      .set_clock = sdhci_set_clock,
        .get_min_clock = sdhci_msm_get_min_clock,
index 167673bd1102dded7633ad2b0a4d33f4d4e9449c..c0d99594da4c89e1822d1015392cf7e10933b51e 100644 (file)
@@ -24,7 +24,7 @@ Reviewed-by: Grant Grundler <grundler@chromium.org>
 
 --- a/include/linux/netdevice.h
 +++ b/include/linux/netdevice.h
-@@ -776,6 +776,16 @@ struct xps_map {
+@@ -765,6 +765,16 @@ struct xps_map {
  #define XPS_MIN_MAP_ALLOC ((L1_CACHE_ALIGN(offsetof(struct xps_map, queues[1])) \
         - sizeof(struct xps_map)) / sizeof(u16))
  
@@ -41,7 +41,7 @@ Reviewed-by: Grant Grundler <grundler@chromium.org>
  /*
   * This structure holds all XPS maps for device.  Maps are indexed by CPU.
   */
-@@ -1379,6 +1389,9 @@ struct net_device_ops {
+@@ -1445,6 +1455,9 @@ struct net_device_ops {
                                                     const struct sk_buff *skb,
                                                     u16 rxq_index,
                                                     u32 flow_id);
index 9adddcabc3867cefe6362f37bef5e20fed717907..6b0272bd72f86186f2e2ded9b24201375c9f8636 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -584,6 +584,13 @@ config XILINX_GMII2RGMII
+@@ -388,6 +388,13 @@ config XILINX_GMII2RGMII
          the Reduced Gigabit Media Independent Interface(RGMII) between
          Ethernet physical media devices and the Gigabit Ethernet controller.
  
  config MICREL_KS8995MA
 --- a/drivers/net/phy/Makefile
 +++ b/drivers/net/phy/Makefile
-@@ -69,6 +69,7 @@ ifdef CONFIG_HWMON
+@@ -50,6 +50,7 @@ ifdef CONFIG_HWMON
  aquantia-objs                 += aquantia_hwmon.o
  endif
  obj-$(CONFIG_AQUANTIA_PHY)    += aquantia.o
 +obj-$(CONFIG_AR40XX_PHY)      += ar40xx.o
- obj-$(CONFIG_AX88796B_PHY)    += ax88796b.o
  obj-$(CONFIG_AT803X_PHY)      += at803x.o
- obj-$(CONFIG_BCM63XX_PHY)     += bcm63xx.o
+ obj-$(CONFIG_AX88796B_PHY)    += ax88796b.o
+ obj-$(CONFIG_BCM54140_PHY)    += bcm54140.o
index b71b28d941c5092ee3ee5b7cf71573e706903835..55b74d1e5645744cb22e6c8cc99b612a32cc0ba2 100644 (file)
@@ -25,9 +25,9 @@ Signed-off-by: Robert Marko <robert.marko@sartura.hr>
 
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -537,6 +537,12 @@ config NXP_TJA11XX_PHY
-       ---help---
-         Currently supports the NXP TJA1100 and TJA1101 PHY.
+@@ -314,6 +314,12 @@ config AT803X_PHY
+       help
+         Currently supports the AR8030, AR8031, AR8033 and AR8035 model
  
 +config QCA807X_PHY
 +      tristate "Qualcomm QCA807X PHYs"
@@ -37,10 +37,10 @@ Signed-off-by: Robert Marko <robert.marko@sartura.hr>
 +
  config QSEMI_PHY
        tristate "Quality Semiconductor PHYs"
-       ---help---
+       help
 --- a/drivers/net/phy/Makefile
 +++ b/drivers/net/phy/Makefile
-@@ -103,6 +103,7 @@ obj-$(CONFIG_MICROSEMI_PHY)        += mscc.o
+@@ -86,6 +86,7 @@ obj-$(CONFIG_MICROSEMI_PHY)  += mscc/
  obj-$(CONFIG_NATIONAL_PHY)    += national.o
  obj-$(CONFIG_NXP_TJA11XX_PHY) += nxp-tja11xx.o
  obj-$(CONFIG_QSEMI_PHY)               += qsemi.o
index 17e9047dfb443a57a9f64bc9ea7a5844b3f16069..df0b70d72e108a4d134ffe1e356f18183c4e0c41 100644 (file)
@@ -2,17 +2,17 @@ From: Christian Lamparter <chunkeey@googlemail.com>
 Subject: SoC: add qualcomm syscon
 --- a/drivers/soc/qcom/Makefile
 +++ b/drivers/soc/qcom/Makefile
-@@ -20,6 +20,7 @@ obj-$(CONFIG_QCOM_SMP2P)     += smp2p.o
+@@ -21,6 +21,7 @@ obj-$(CONFIG_QCOM_SMP2P)     += smp2p.o
  obj-$(CONFIG_QCOM_SMSM)       += smsm.o
  obj-$(CONFIG_QCOM_SOCINFO)    += socinfo.o
  obj-$(CONFIG_QCOM_WCNSS_CTRL) += wcnss_ctrl.o
 +obj-$(CONFIG_QCOM_TCSR)        += qcom_tcsr.o
  obj-$(CONFIG_QCOM_APR) += apr.o
- obj-$(CONFIG_QCOM_LLCC) += llcc-slice.o
- obj-$(CONFIG_QCOM_SDM845_LLCC) += llcc-sdm845.o
+ obj-$(CONFIG_QCOM_LLCC) += llcc-qcom.o
+ obj-$(CONFIG_QCOM_RPMHPD) += rpmhpd.o
 --- a/drivers/soc/qcom/Kconfig
 +++ b/drivers/soc/qcom/Kconfig
-@@ -183,6 +183,13 @@ config QCOM_SOCINFO
+@@ -189,6 +189,13 @@ config QCOM_SOCINFO
         Say yes here to support the Qualcomm socinfo driver, providing
         information about the SoC to user space.
  
index 0447fb601207ac97e5ec0e7fa40f926febd4706c..aef58ee50e9bf41223dc34d1c14d6a86d016ea29 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
 
 --- a/arch/arm/boot/dts/Makefile
 +++ b/arch/arm/boot/dts/Makefile
-@@ -837,11 +837,61 @@ dtb-$(CONFIG_ARCH_QCOM) += \
+@@ -902,11 +902,61 @@ dtb-$(CONFIG_ARCH_QCOM) += \
        qcom-apq8074-dragonboard.dtb \
        qcom-apq8084-ifc6540.dtb \
        qcom-apq8084-mtp.dtb \
@@ -70,5 +70,5 @@ Signed-off-by: John Crispin <john@phrozen.org>
 +      qcom-ipq4029-gl-s1300.dtb \
 +      qcom-ipq4029-mr33.dtb \
        qcom-ipq8064-ap148.dtb \
+       qcom-ipq8064-rb3011.dtb \
        qcom-msm8660-surf.dtb \
-       qcom-msm8960-cdp.dtb \
index 3cc032fdd24bdb1758a821314077e4385f127712..27d4d7f1e5e25df46b5612d9eb8f977330b338a6 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/of/fdt.c
 +++ b/drivers/of/fdt.c
-@@ -1059,6 +1059,9 @@ int __init early_init_dt_scan_chosen(uns
+@@ -1055,6 +1055,9 @@ int __init early_init_dt_scan_chosen(uns
        p = of_get_flat_dt_prop(node, "bootargs", &l);
        if (p != NULL && l > 0)
                strlcpy(data, p, min(l, COMMAND_LINE_SIZE));