build: explicitly unexport CONFIG_SITE
authorFelix Fietkau <nbd@openwrt.org>
Sun, 18 Jan 2015 00:37:18 +0000 (00:37 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 18 Jan 2015 00:37:18 +0000 (00:37 +0000)
On systems with CONFIG_SITE in the environment (e.g. OpenSUSE) make will export
the CONFIG_SITE set in include/package.mk by default. This will cause host
builds to get the target site configuration, leading to all kinds of weirdness
(wrong pointer size, wrong endianess).

Fix this by explicitly unexporting CONFIG_SITE. The explicit export for the
target builds overrides the unexport, so the target builds will still correctly
get the site config.

Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
SVN-Revision: 44019

include/package.mk

index 2c34a5850c9bbce16ee9ba5fd1c956c76690a916..8208e36cfc452ddb0f94245f694d956b42897d83 100644 (file)
@@ -131,7 +131,7 @@ CONFIG_SITE:=$(INCLUDE_DIR)/site/$(REAL_GNU_TARGET_NAME)
 CUR_MAKEFILE:=$(filter-out Makefile,$(firstword $(MAKEFILE_LIST)))
 SUBMAKE:=$(NO_TRACE_MAKE) $(if $(CUR_MAKEFILE),-f $(CUR_MAKEFILE))
 PKG_CONFIG_PATH=$(STAGING_DIR)/usr/lib/pkgconfig:$(STAGING_DIR)/usr/share/pkgconfig
-unexport QUIET
+unexport QUIET CONFIG_SITE
 
 ifeq ($(DUMP)$(filter prereq clean refresh update,$(MAKECMDGOALS)),)
   ifneq ($(if $(QUILT),,$(CONFIG_AUTOREBUILD)),)