bzip2: add symlink to binary
authorDaniel Golle <daniel@makrotopia.org>
Wed, 5 Jul 2017 14:25:23 +0000 (16:25 +0200)
committerJo-Philipp Wich <jo@mein.io>
Wed, 13 Dec 2017 15:23:38 +0000 (16:23 +0100)
Other distributions incl. the OpenWrt ImageBuilder and SDK
expect to find the bzip2 executable in /bin.
Create a symlink at that location for compatibility.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
(cherry picked from commit eb7c14d512482e18d05f61afa44205167ea094c0)

package/utils/bzip2/Makefile

index c17dee136bc366dbdba86117106427a2713def15..62c255a907e8748018a1f4b3f4db468caf3f3c03 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bzip2
 PKG_VERSION:=1.0.6
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.bzip.org/$(PKG_VERSION)
@@ -82,6 +82,8 @@ endef
 define Package/bzip2/install
        $(INSTALL_DIR) $(1)/usr/bin/
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/bzip2-shared $(1)/usr/bin/bzip2
+       $(INSTALL_DIR) $(1)/bin/
+       $(LN) ../usr/bin/bzip2 $(1)/bin/bzip2
 endef
 
 HOST_CFLAGS += \