kirkwood: support Linksys boot counter on EA[34]500
authorLuka Perkov <luka@openwrt.org>
Tue, 10 Nov 2015 00:16:37 +0000 (00:16 +0000)
committerLuka Perkov <luka@openwrt.org>
Tue, 10 Nov 2015 00:16:37 +0000 (00:16 +0000)
This is done with existing code from the WRT1900AC port.
It makes sure the "auto_recovery" bootloader option is set,
and resets the s_env boot counter after a successful boot.

This gives users without a serial console connection some
measure of safety.

Signed-off-by: Claudio Leite <leitec@staticky.com>
SVN-Revision: 47433

package/system/mtd/src/Makefile
target/linux/kirkwood/base-files/etc/init.d/linksys_recovery [new file with mode: 0755]

index 40a165e4e64dbd760396cee8d57bd3439d019bc2..1e02ce94ee25b10e0a7f9e072af8aa3386bc083f 100644 (file)
@@ -11,6 +11,7 @@ obj.bcm53xx = $(obj.brcm)
 obj.brcm63xx = imagetag.o
 obj.ramips = $(obj.seama)
 obj.mvebu = linksys_bootcount.o
+obj.kirkwood = linksys_bootcount.o
 
 ifdef FIS_SUPPORT
   obj += fis.o
diff --git a/target/linux/kirkwood/base-files/etc/init.d/linksys_recovery b/target/linux/kirkwood/base-files/etc/init.d/linksys_recovery
new file mode 100755 (executable)
index 0000000..3f1b762
--- /dev/null
@@ -0,0 +1,20 @@
+#!/bin/sh /etc/rc.common
+# Copyright (C) 2015 OpenWrt.org
+
+START=97
+boot() {
+. /lib/functions.sh
+. /lib/kirkwood.sh
+
+case $(kirkwood_board_name) in
+       linksys-audi|linksys-viper)
+               # make sure auto_recovery in uboot is always on
+               AUTO_RECOVERY_ENA="`fw_printenv -n auto_recovery`"
+               if [ "$AUTO_RECOVERY_ENA" != "yes" ] ; then
+                       fw_setenv auto_recovery yes
+               fi
+               # reset the boot counter
+               mtd resetbc s_env
+               ;;
+esac
+}