build: Honour NO_COLOR in include/scan.mk
authorR. Diez <rdiezmail-openwrt@yahoo.com>
Mon, 21 Jan 2019 18:32:06 +0000 (18:32 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 17 Feb 2019 18:22:04 +0000 (19:22 +0100)
The sender domain has a DMARC Reject/Quarantine policy which disallows
sending mailing list messages using the original "From" header.

To mitigate this problem, the original message has been wrapped
automatically by the mailing list software.
Hi all:

This is my first OpenWrt patch. I am a clean, pure newbie! 8-)

Honour NO_COLOR in Makefile function 'progress' in include/scan.mk, in the same way that include/verbose.mk does.

Signed-off-by: R. Diez <rdiezmail-openwrt@yahoo.com>
include/scan.mk

index e6b21b27b009ce14f8683980add8d2be3bea9340..724dbfaf179f2bf343d36de38549c7b647a3dff5 100644 (file)
@@ -19,9 +19,15 @@ else
 endif
 
 ifeq ($(IS_TTY),1)
-  define progress
+  ifneq ($(strip $(NO_COLOR)),1)
+    define progress
        printf "\033[M\r$(1)" >&2;
-  endef
+    endef
+  else
+    define progress
+       :;
+    endef
+  endif
 else
   define progress
        :;