update to the latest stable kernels
authorImre Kaloz <kaloz@openwrt.org>
Wed, 24 Nov 2010 18:50:11 +0000 (18:50 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Wed, 24 Nov 2010 18:50:11 +0000 (18:50 +0000)
SVN-Revision: 24136

43 files changed:
include/kernel-version.mk
target/linux/adm5120/Makefile
target/linux/adm8668/Makefile
target/linux/ar7/Makefile
target/linux/ar71xx/Makefile
target/linux/at91/Makefile
target/linux/atheros/Makefile
target/linux/au1000/Makefile
target/linux/avr32/Makefile
target/linux/brcm63xx/Makefile
target/linux/cobalt/Makefile
target/linux/ep93xx/Makefile
target/linux/etrax/Makefile
target/linux/gemini/Makefile
target/linux/generic/patches-2.6.32/040-use_ext4_for_ext23.patch
target/linux/generic/patches-2.6.32/041-ext4_do_not_override_ext23.patch
target/linux/generic/patches-2.6.32/042-ext4_add_ext23_module_aliases.patch
target/linux/generic/patches-2.6.32/980-vm_exports.patch
target/linux/generic/patches-2.6.35/030-pci_disable_common_quirks.patch
target/linux/generic/patches-2.6.35/180-netfilter_depends.patch
target/linux/generic/patches-2.6.35/975-ssb_update.patch
target/linux/generic/patches-2.6.35/980-vm_exports.patch
target/linux/generic/patches-2.6.36/103-netfilter_layer7_2.6.36_fix.patch
target/linux/generic/patches-2.6.36/180-netfilter_depends.patch
target/linux/generic/patches-2.6.36/980-vm_exports.patch
target/linux/ifxmips/Makefile
target/linux/iop32x/Makefile
target/linux/ixp4xx/Makefile
target/linux/kirkwood/Makefile
target/linux/malta/Makefile
target/linux/omap24xx/Makefile
target/linux/omap35xx/Makefile
target/linux/orion/Makefile
target/linux/ppc40x/Makefile
target/linux/ppc44x/Makefile
target/linux/pxa/Makefile
target/linux/rb532/Makefile
target/linux/rdc/Makefile
target/linux/realview/Makefile
target/linux/sibyte/Makefile
target/linux/uml/Makefile
target/linux/x86/Makefile
target/linux/xburst/Makefile

index bdfa92dea5f231dee89ec26e353ab2c4fcbff3b5..21a1e034e81942fce58c5a5855d61d2bc613c428 100644 (file)
@@ -11,8 +11,8 @@ endif
 ifeq ($(LINUX_VERSION),2.6.31.14)
   LINUX_KERNEL_MD5SUM:=3e7feb224197d8e174a90dd3759979fd
 endif
-ifeq ($(LINUX_VERSION),2.6.32.25)
-  LINUX_KERNEL_MD5SUM:=0d6ad4e7e387f56c5b5831beb97c0c1f
+ifeq ($(LINUX_VERSION),2.6.32.26)
+  LINUX_KERNEL_MD5SUM:=bdb37b8e48aaf33d9bd6e2af3ae2f1ea
 endif
 ifeq ($(LINUX_VERSION),2.6.33.7)
   LINUX_KERNEL_MD5SUM:=2cea51deeaa0620a07d005ec3b148f06
@@ -20,11 +20,11 @@ endif
 ifeq ($(LINUX_VERSION),2.6.34.7)
   LINUX_KERNEL_MD5SUM:=8964e26120e84844998a673464a980ea
 endif
-ifeq ($(LINUX_VERSION),2.6.35.8)
-  LINUX_KERNEL_MD5SUM:=10ccef307e81fb405b01457f312a8c66
+ifeq ($(LINUX_VERSION),2.6.35.9)
+  LINUX_KERNEL_MD5SUM:=18d339e9229560e73c4249dffdc3fd90
 endif
-ifeq ($(LINUX_VERSION),2.6.36)
-  LINUX_KERNEL_MD5SUM:=61f3739a73afb6914cb007f37fb09b62
+ifeq ($(LINUX_VERSION),2.6.36.1)
+  LINUX_KERNEL_MD5SUM:=0f1398ad1fcfc14f2420010bc8a03ca9
 endif
 
 # disable the md5sum check for unknown kernel versions
index 0c319a949bfbac5ada5c988da530b1a97ed92eec..18110f9900efcde06529917397c07d7e7b92d7a2 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 BOARD:=adm5120
 BOARDNAME:=Infineon/ADMtek ADM5120
-LINUX_VERSION:=2.6.32.25
+LINUX_VERSION:=2.6.32.26
 SUBTARGETS:=router_le router_be
 INITRAMFS_EXTRA_FILES:=
 
index 9021e39256eb1ed445e1f40c6e49817d70d65d43..4eb06d168108dba79004599553f2851dc667b664 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=adm8668
 BOARDNAME:=Infineon WildPass ADM8668
 FEATURES:=squashfs
 
-LINUX_VERSION:=2.6.36
+LINUX_VERSION:=2.6.36.1
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-rt61-pci
index 40d162112cb357c21d9153d59bbb5f0ffa983187..c3cccfa454f3999df800363cdb8f7099e05093a8 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=ar7
 BOARDNAME:=TI AR7
 FEATURES:=squashfs jffs2 atm
 
-LINUX_VERSION:=2.6.32.25
+LINUX_VERSION:=2.6.32.26
 
 include $(INCLUDE_DIR)/target.mk
 
index 38fa8ff7df05ec70aa87167ab2ae533e1c459a0a..4b5a8a79d73c69e8d1027b0df9fbb751df4e871f 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 targz
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
 SUBTARGETS:=generic nand
 
-LINUX_VERSION:=2.6.32.25
+LINUX_VERSION:=2.6.32.26
 
 include $(INCLUDE_DIR)/target.mk
 
index d2308f376c1a532dd3bd272fcf58a8dca5987474..03ebe22ce4c649b7d573a2ae0b13a1fd81bc6d04 100644 (file)
@@ -13,7 +13,7 @@ BOARDNAME:=Atmel AT91
 FEATURES:=squashfs jffs2 targz
 CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -funit-at-a-time
 
-LINUX_VERSION:=2.6.35.8
+LINUX_VERSION:=2.6.35.9
 DEVICE_TYPE=
 
 include $(INCLUDE_DIR)/target.mk
index 6e29fd7d98b819c534a86d36fd4cf379e2b19060..faef4d6be4d3a78b60d09f0943b3e34888a753b0 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=atheros
 BOARDNAME:=Atheros AR231x/AR5312
 FEATURES:=squashfs jffs2
 
-LINUX_VERSION:=2.6.32.25
+LINUX_VERSION:=2.6.32.26
 
 include $(INCLUDE_DIR)/target.mk
 
index b4272157433db687e170450de990ba312f7b36f7..b2b134179302881b7afcfe8c132e22f453194b71 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=RMI/AMD AU1x00
 FEATURES:=jffs2 usb pci
 SUBTARGETS=au1500 au1550
 
-LINUX_VERSION:=2.6.35.8
+LINUX_VERSION:=2.6.35.9
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini yamonenv
index 62d249610e29c6052292fc4fb4ec5ccd0fd898ad..6a3d6d6ef21d3149288716d08bc8ba7f02b304cb 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Atmel AVR32
 FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.36
+LINUX_VERSION:=2.6.36.1
 
 include $(INCLUDE_DIR)/target.mk
 
index 49573ad562fb888cc6648866a165c21357f8f201..5bdc10384d1e9f48622196e3f0265dd5e4941b2c 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
 FEATURES:=squashfs jffs2 usb atm pci pcmcia
-LINUX_VERSION:=2.6.35.8
+LINUX_VERSION:=2.6.35.9
 
 include $(INCLUDE_DIR)/target.mk
 
index f7beb95920eb2ec0450daa672a8c111860d7e3cc..32b766d677efa96927c1a846ae6b1ccf530d9a09 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Cobalt Microservers
 FEATURES:=targz pci ext4
 CFLAGS:=-O2 -pipe -mtune=r5000 -funit-at-a-time
 
-LINUX_VERSION:=2.6.32.25
+LINUX_VERSION:=2.6.32.26
 
 include $(INCLUDE_DIR)/target.mk
 
index c429e2e7673982b371bfe27314a896e1873decd1..6c8b05a2df7fc8b2f87da8872b30b394767974ba 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Cirrus Logic EP93xx
 FEATURES:=squashfs jffs2 ext4 targz usb
 CFLAGS:=-Os -pipe -march=armv4t -funit-at-a-time
 
-LINUX_VERSION:=2.6.36
+LINUX_VERSION:=2.6.36.1
 
 include $(INCLUDE_DIR)/target.mk
 
index 2e6ccdd8b1bf6fd19a126de5a7375b383d18f216..f6e04a497ea5d8650205559646fe8aa6eb9f7c81 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=etrax
 MAINTAINER:=Claudio Mignanti <c.mignanti@gmail.com>
 BOARDNAME:=Axis ETRAX 100LX
 FEATURES:=squashfs jffs2 usb
-LINUX_VERSION:=2.6.32.25
+LINUX_VERSION:=2.6.32.26
 DEVICE_TYPE=
 
 include $(INCLUDE_DIR)/target.mk
index 66e956b04f465b8c0100218391b824f8b808e03c..e751dca056b151e6144c7bff71cfd835a0abe2f7 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 CFLAGS:=-Os -pipe -march=armv4 -mtune=arm9tdmi -funit-at-a-time
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.32.25
+LINUX_VERSION:=2.6.32.26
 
 include $(INCLUDE_DIR)/target.mk
 
index d5824f1bdb2b9147d548f8776847c22ba7c2e5c9..db2fc3849ff2eabc7c62c658e59a7dff248d8560 100644 (file)
@@ -37,7 +37,7 @@ Signed-off-by: "Theodore Ts'o" <tytso@mit.edu>
        depends on EXT4_FS
 --- a/fs/ext4/super.c
 +++ b/fs/ext4/super.c
-@@ -3989,6 +3989,58 @@ static int ext4_get_sb(struct file_syste
+@@ -3994,6 +3994,58 @@ static int ext4_get_sb(struct file_syste
        return get_sb_bdev(fs_type, flags, dev_name, data, ext4_fill_super,mnt);
  }
  
@@ -96,7 +96,7 @@ Signed-off-by: "Theodore Ts'o" <tytso@mit.edu>
  static struct file_system_type ext4_fs_type = {
        .owner          = THIS_MODULE,
        .name           = "ext4",
-@@ -4018,11 +4070,15 @@ static int __init init_ext4_fs(void)
+@@ -4024,11 +4076,15 @@ static int __init init_ext4_fs(void)
        err = init_inodecache();
        if (err)
                goto out1;
@@ -112,7 +112,7 @@ Signed-off-by: "Theodore Ts'o" <tytso@mit.edu>
        destroy_inodecache();
  out1:
        exit_ext4_xattr();
-@@ -4038,6 +4094,8 @@ out4:
+@@ -4044,6 +4100,8 @@ out4:
  
  static void __exit exit_ext4_fs(void)
  {
index 19b5626eef714f2d9885a863e453885fde42eafb..f45973e7c7fdf881a306507d139e820620fb1d96 100644 (file)
@@ -26,7 +26,7 @@ Signed-off-by: "Theodore Ts'o" <tytso@mit.edu>
          Allow the ext4 file system driver code to be used for ext2 or
 --- a/fs/ext4/super.c
 +++ b/fs/ext4/super.c
-@@ -3989,7 +3989,7 @@ static int ext4_get_sb(struct file_syste
+@@ -3994,7 +3994,7 @@ static int ext4_get_sb(struct file_syste
        return get_sb_bdev(fs_type, flags, dev_name, data, ext4_fill_super,mnt);
  }
  
@@ -35,7 +35,7 @@ Signed-off-by: "Theodore Ts'o" <tytso@mit.edu>
  static struct file_system_type ext2_fs_type = {
        .owner          = THIS_MODULE,
        .name           = "ext2",
-@@ -4015,7 +4015,7 @@ static inline void register_as_ext2(void
+@@ -4020,7 +4020,7 @@ static inline void register_as_ext2(void
  static inline void unregister_as_ext2(void) { }
  #endif
  
index 7ac97b501094293a244bdc7f773b18bab11e2250..2bf863b2d45079839ce0f53b11206e12d927a0a6 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: "Theodore Ts'o" <tytso@mit.edu>
 
 --- a/fs/ext4/super.c
 +++ b/fs/ext4/super.c
-@@ -4010,6 +4010,7 @@ static inline void unregister_as_ext2(vo
+@@ -4015,6 +4015,7 @@ static inline void unregister_as_ext2(vo
  {
        unregister_filesystem(&ext2_fs_type);
  }
@@ -23,7 +23,7 @@ Signed-off-by: "Theodore Ts'o" <tytso@mit.edu>
  #else
  static inline void register_as_ext2(void) { }
  static inline void unregister_as_ext2(void) { }
-@@ -4036,6 +4037,7 @@ static inline void unregister_as_ext3(vo
+@@ -4041,6 +4042,7 @@ static inline void unregister_as_ext3(vo
  {
        unregister_filesystem(&ext3_fs_type);
  }
index 5d55fa964241990458ac7941ff26d557ed20f9f1..d0d98b2e40bb70160b693b1be212cd09aa82667e 100644 (file)
@@ -68,7 +68,7 @@
   * macro override instead of weak attribute alias, to workaround
 --- a/kernel/sched.c
 +++ b/kernel/sched.c
-@@ -6224,6 +6224,7 @@ int can_nice(const struct task_struct *p
+@@ -6223,6 +6223,7 @@ int can_nice(const struct task_struct *p
        return (nice_rlim <= p->signal->rlim[RLIMIT_NICE].rlim_cur ||
                capable(CAP_SYS_NICE));
  }
@@ -96,7 +96,7 @@
   * We enter with non-exclusive mmap_sem (to exclude vma changes,
 --- a/mm/vmalloc.c
 +++ b/mm/vmalloc.c
-@@ -1172,6 +1172,7 @@ void unmap_kernel_range(unsigned long ad
+@@ -1181,6 +1181,7 @@ void unmap_kernel_range(unsigned long ad
        vunmap_page_range(addr, end);
        flush_tlb_kernel_range(addr, end);
  }
  
  int map_vm_area(struct vm_struct *area, pgprot_t prot, struct page ***pages)
  {
-@@ -1287,6 +1288,7 @@ struct vm_struct *get_vm_area(unsigned l
+@@ -1296,6 +1297,7 @@ struct vm_struct *get_vm_area(unsigned l
        return __get_vm_area_node(size, 1, flags, VMALLOC_START, VMALLOC_END,
                                -1, GFP_KERNEL, __builtin_return_address(0));
  }
index 0f4789a704b83258f861a01d46bb49d50d2b462b..5fc49494a754924d694213778ecfc23b4e548fe0 100644 (file)
@@ -23,7 +23,7 @@
  /* The Mellanox Tavor device gives false positive parity errors
   * Mark this device with a broken_parity_status, to allow
   * PCI scanning code to "skip" this now blacklisted device.
-@@ -1904,7 +1905,9 @@ static void __devinit fixup_rev1_53c810(
+@@ -1924,7 +1925,9 @@ static void __devinit fixup_rev1_53c810(
        }
  }
  DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_NCR, PCI_DEVICE_ID_NCR_53C810, fixup_rev1_53c810);
@@ -33,7 +33,7 @@
  /* Enable 1k I/O space granularity on the Intel P64H2 */
  static void __devinit quirk_p64h2_1k_io(struct pci_dev *dev)
  {
-@@ -2560,6 +2563,7 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_I
+@@ -2580,6 +2583,7 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_I
  DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_INTEL, 0x1518, quirk_i82576_sriov);
  
  #endif        /* CONFIG_PCI_IOV */
index 5532e2b35035be0785ceb3545de219b9ebef984c..977f892d467d3280131935f229c980124aa52a5c 100644 (file)
@@ -8,7 +8,7 @@
        depends on NETFILTER_ADVANCED
        help
          H.323 is a VoIP signalling protocol from ITU-T. As one of the most
-@@ -550,7 +549,6 @@ config NETFILTER_XT_TARGET_SECMARK
+@@ -562,7 +561,6 @@ config NETFILTER_XT_TARGET_SECMARK
  
  config NETFILTER_XT_TARGET_TCPMSS
        tristate '"TCPMSS" target support'
index 6cf41cc6a0809bfa111b79f280c0cc640e054fa9..35d0515160745573811d6dbbf17efe1acd679dce 100644 (file)
                        tx_ring_dma + size > DMA_BIT_MASK(30)) {
                        kfree(tx_ring);
                        goto out_err;
-@@ -2176,12 +2169,14 @@ static int __devinit b44_init_one(struct
+@@ -2174,12 +2167,14 @@ static int __devinit b44_init_one(struct
                        "Failed to powerup the bus\n");
                goto err_out_free_dev;
        }
index 8a021e24c70a71d4c069acc1e09c54d94f6bf392..5ca94b25a2d71cd98762be2e09fcd222845998ac 100644 (file)
@@ -76,7 +76,7 @@
   * macro override instead of weak attribute alias, to workaround
 --- a/kernel/sched.c
 +++ b/kernel/sched.c
-@@ -4269,6 +4269,7 @@ int can_nice(const struct task_struct *p
+@@ -4262,6 +4262,7 @@ int can_nice(const struct task_struct *p
        return (nice_rlim <= task_rlimit(p, RLIMIT_NICE) ||
                capable(CAP_SYS_NICE));
  }
   * We enter with non-exclusive mmap_sem (to exclude vma changes,
 --- a/mm/vmalloc.c
 +++ b/mm/vmalloc.c
-@@ -1173,6 +1173,7 @@ void unmap_kernel_range(unsigned long ad
+@@ -1182,6 +1182,7 @@ void unmap_kernel_range(unsigned long ad
        vunmap_page_range(addr, end);
        flush_tlb_kernel_range(addr, end);
  }
  
  int map_vm_area(struct vm_struct *area, pgprot_t prot, struct page ***pages)
  {
-@@ -1288,6 +1289,7 @@ struct vm_struct *get_vm_area(unsigned l
+@@ -1297,6 +1298,7 @@ struct vm_struct *get_vm_area(unsigned l
        return __get_vm_area_node(size, 1, flags, VMALLOC_START, VMALLOC_END,
                                -1, GFP_KERNEL, __builtin_return_address(0));
  }
index e9aa3c967fa4f74358094b07fc39e11c4f7428bb..a2f6ff208ff1be7be684c2ef526b385c587baa33 100644 (file)
@@ -1,6 +1,6 @@
 --- a/net/netfilter/Kconfig
 +++ b/net/netfilter/Kconfig
-@@ -781,6 +781,27 @@ config NETFILTER_XT_MATCH_IPVS
+@@ -761,6 +761,27 @@ config NETFILTER_XT_MATCH_IPVS
  
          If unsure, say N.
  
@@ -28,7 +28,7 @@
  config NETFILTER_XT_MATCH_LENGTH
        tristate '"length" match support'
        depends on NETFILTER_ADVANCED
-@@ -966,26 +987,11 @@ config NETFILTER_XT_MATCH_STATE
+@@ -946,26 +967,11 @@ config NETFILTER_XT_MATCH_STATE
  
          To compile it as a module, choose M here.  If unsure, say N.
  
index 65c4d44c2b3b652ce0897820a74b11de6f51f3df..4cf9fcf158c8ebd7567a4edfaff707f01cb777a1 100644 (file)
@@ -8,7 +8,7 @@
        depends on NETFILTER_ADVANCED
        help
          H.323 is a VoIP signalling protocol from ITU-T. As one of the most
-@@ -557,7 +556,6 @@ config NETFILTER_XT_TARGET_SECMARK
+@@ -569,7 +568,6 @@ config NETFILTER_XT_TARGET_SECMARK
  
  config NETFILTER_XT_TARGET_TCPMSS
        tristate '"TCPMSS" target support'
index 8cd8b16c534f1254a8c40bdb29cb3cccc53f303e..d748b9b3f062f3d35d40a03a511f39b8902a866c 100644 (file)
@@ -76,7 +76,7 @@
   * macro override instead of weak attribute alias, to workaround
 --- a/kernel/sched.c
 +++ b/kernel/sched.c
-@@ -4446,6 +4446,7 @@ int can_nice(const struct task_struct *p
+@@ -4439,6 +4439,7 @@ int can_nice(const struct task_struct *p
        return (nice_rlim <= task_rlimit(p, RLIMIT_NICE) ||
                capable(CAP_SYS_NICE));
  }
   * We enter with non-exclusive mmap_sem (to exclude vma changes,
 --- a/mm/vmalloc.c
 +++ b/mm/vmalloc.c
-@@ -1177,6 +1177,7 @@ void unmap_kernel_range(unsigned long ad
+@@ -1186,6 +1186,7 @@ void unmap_kernel_range(unsigned long ad
        vunmap_page_range(addr, end);
        flush_tlb_kernel_range(addr, end);
  }
  
  int map_vm_area(struct vm_struct *area, pgprot_t prot, struct page ***pages)
  {
-@@ -1292,6 +1293,7 @@ struct vm_struct *get_vm_area(unsigned l
+@@ -1301,6 +1302,7 @@ struct vm_struct *get_vm_area(unsigned l
        return __get_vm_area_node(size, 1, flags, VMALLOC_START, VMALLOC_END,
                                -1, GFP_KERNEL, __builtin_return_address(0));
  }
index 53558ef79bd85ea5cddd7370e5d56988de5677e9..9de534358fc93e48ed53cac50a6a6aa4e38a9cf7 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Infineon Mips
 FEATURES:=squashfs jffs2 atm
 SUBTARGETS:=danube ar9
 
-LINUX_VERSION:=2.6.35.8
+LINUX_VERSION:=2.6.35.9
 
 CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
 
index 4785ae6eba4a62f6d97baa6bd24b7be7a2cbed91..c5c0d27d5ff60b9285315f2701bbdf3458d845b5 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Intel IOP32x
 FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.32.25
+LINUX_VERSION:=2.6.32.26
 
 include $(INCLUDE_DIR)/target.mk
 
index 2c5bb4fe1285a330d799107dced68bb3424115e5..5a380900ffed72e4ef9834b181ee120934518af0 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 SUBTARGETS=generic harddisk
 
-LINUX_VERSION:=2.6.32.25
+LINUX_VERSION:=2.6.32.26
 
 include $(INCLUDE_DIR)/target.mk
 
index eaca1658baf13ebe5a22e995fa058000a01f84fb..1dbd5b14501ad95188cac42dc04105859bb400ad 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Marvell Kirkwood
 FEATURES:=targz usb jffs2
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.35.8
+LINUX_VERSION:=2.6.35.9
 
 include $(INCLUDE_DIR)/target.mk
 
index f6882624583b3c21a3ee0fe160c01d84ba636e40..53afdf2696d041301d0bfe92c10cff7243cef531 100644 (file)
@@ -12,7 +12,7 @@ CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
 SUBTARGETS:=le be
 INITRAMFS_EXTRA_FILES:=
 
-LINUX_VERSION:=2.6.36
+LINUX_VERSION:=2.6.36.1
 
 include $(INCLUDE_DIR)/target.mk
 
index 3f114b0770d7be1e27bbbff28ee91d07b5bf17e5..223376c3b49e05d7672a0edbc087b81a8e52c02d 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=TI OMAP-24xx
 MAINTAINER:=Michael Buesch <mb@bu3sch.de>
 FEATURES:=targz squashfs jffs2 usb usbgadget display gpio audio
 
-LINUX_VERSION:=2.6.36
+LINUX_VERSION:=2.6.36.1
 
 define Target/Description
        TI OMAP-24xx
index cb08bf24675ed8310fa110064b7b33f34c0545d0..e149392bb7e649731c3afa5729d3638717dfc495 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=TI OMAP35xx
 FEATURES:=broken
 SUBTARGETS=beagleboard gumstix
 
-LINUX_VERSION:=2.6.32.25
+LINUX_VERSION:=2.6.32.26
 KERNELNAME:="uImage"
 
 DEVICE_TYPE=developerboard
index 7cf9e02a7d057c23e4974a51b7805056d94f02ed..627e2e3a493e078c6a577355f46b0ef79de57416 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=generic harddisk
 CFLAGS=-Os -pipe -march=armv5t -mtune=xscale -funit-at-a-time
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.36
+LINUX_VERSION:=2.6.36.1
 
 include $(INCLUDE_DIR)/target.mk
 
index d1508a5de9dc28bbfc10d91599b885dc56f5a94e..8dac42bfbdfc7b28879ca747d1b3ce66456833ba 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=405
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.32.25
+LINUX_VERSION:=2.6.32.26
 
 include $(INCLUDE_DIR)/target.mk
 
index c2c4eb5912cb5a145836ca494d21f522b6859cd4..6dee281049ba7797897c38828601d9dad851fe12 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=440
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.32.25
+LINUX_VERSION:=2.6.32.26
 
 include $(INCLUDE_DIR)/target.mk
 
index 8da585c5e35a291cdaa68009a86db9e851296bdc..8496490b8c24f9dcf442b0673f7abdee93b5390c 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Marvell/Intel PXA2xx
 FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.32.25
+LINUX_VERSION:=2.6.32.26
 
 include $(INCLUDE_DIR)/target.mk
 
index 3a2afbe45354ebad586382a662842a8469b7c766..7114b1b4d012e24549e061300c070a7472770e4c 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=rb532
 BOARDNAME:=Mikrotik RouterBoard 532
 FEATURES:=jffs2 pci targz
 
-LINUX_VERSION:=2.6.32.25
+LINUX_VERSION:=2.6.32.26
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532
index be5936cfcc6d79d54e9d07aa610c3054a13a0318..9e3f3c19c6bd64a1d4b2ad08c57a7d2d2df06f3f 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=RDC 321x
 FEATURES:=squashfs jffs2 pci usb pcmcia
 CFLAGS:=-Os -pipe -march=i486 -mtune=i486 -funit-at-a-time
 
-LINUX_VERSION:=2.6.32.25
+LINUX_VERSION:=2.6.32.26
 
 include $(INCLUDE_DIR)/target.mk
 
index 4481b20b04257d308b791b8ef645f585dc8c8f48..1326b42c62c8512030fabe8d636c28ff08c77bfb 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=ARM Ltd. Realview board (qemu)
 FEATURES:=squashfs jffs2 fpu
 CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -funit-at-a-time
 
-LINUX_VERSION:=2.6.36
+LINUX_VERSION:=2.6.36.1
 
 include $(INCLUDE_DIR)/target.mk
 
index 5b58ebe6c7f67b44412d70c543c12c885dae8670..92b6a2a5a8d895877c7035cc6eb8566656956f48 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=fpu
 CFLAGS:=-Os -pipe -march=sb1 -funit-at-a-time
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.32.25
+LINUX_VERSION:=2.6.32.26
 
 include $(INCLUDE_DIR)/target.mk
 
index 94a08f3bd0ceb0239f88b9afebd7e96928a83721..034096be884abfad035a37c0c92c834e81dd4376 100644 (file)
@@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
 FEATURES:=ext4 audio
 LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
 
-LINUX_VERSION:=2.6.32.25
+LINUX_VERSION:=2.6.32.26
 
 include $(INCLUDE_DIR)/target.mk
 
index 5aacca58fbb6c88726966252b57168d065ed2872..a3518af77899704d4e6ae2146314724919af7a21 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=x86
 FEATURES:=squashfs jffs2 ext4 vdi vmdk pcmcia targz
 SUBTARGETS=generic olpc xen_domu ep80579 net5501 kvm_guest geos
 
-LINUX_VERSION:=2.6.32.25
+LINUX_VERSION:=2.6.32.26
 
 include $(INCLUDE_DIR)/target.mk
 
index d2270a0b14397aa3d855a0fe146254643d230350..498f80edb0f5af825f941070bc73ac65b617ee61 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Ingenic XBurst
 FEATURES:=jffs2 targz ubifs audio
 SUBTARGETS:=qi_lb60 n516 n526 id800wt
 
-LINUX_VERSION:=2.6.36
+LINUX_VERSION:=2.6.36.1
 
 DEVICE_TYPE=other