ccache, samba36: fix samba.org addresses to use https
authorHannu Nyman <hannu.nyman@iki.fi>
Wed, 1 Feb 2017 21:17:37 +0000 (23:17 +0200)
committerJo-Philipp Wich <jo@mein.io>
Wed, 1 Feb 2017 23:14:03 +0000 (00:14 +0100)
samba.org has started to enforce https and
currently plain http downloads with curl/wget fail,
so convert samba.org download links to use https.

Modernise links at the same time.

Also convert samba.org URL fields to have https.

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
config/Config-devel.in
package/network/services/ppp/Makefile
package/network/services/samba36/Makefile
tools/ccache/Makefile

index d953e6679a8f861e9ef7396d08ec515b1ae7cf8c..30fbd6f7a9964e08835a9ec7998e06d4f929c7aa 100644 (file)
@@ -67,7 +67,7 @@ menuconfig DEVEL
                bool "Use ccache" if DEVEL
                default n
                help
                bool "Use ccache" if DEVEL
                default n
                help
-                 Compiler cache; see http://ccache.samba.org/.
+                 Compiler cache; see https://ccache.samba.org/
 
        config EXTERNAL_KERNEL_TREE
                string "Use external kernel tree" if DEVEL
 
        config EXTERNAL_KERNEL_TREE
                string "Use external kernel tree" if DEVEL
index 8b58c1c06fbeb50c05f7da21e89418143bac6e1b..669e6534fe802d9b89fed710b388cd34be785047 100644 (file)
@@ -30,7 +30,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/ppp/Default
   SECTION:=net
   CATEGORY:=Network
 define Package/ppp/Default
   SECTION:=net
   CATEGORY:=Network
-  URL:=http://ppp.samba.org/
+  URL:=https://ppp.samba.org/
 endef
 
 define Package/ppp
 endef
 
 define Package/ppp
index 1311e0900122073637dd3dc6c6945d66157faf68..fcf772195ac369c12622d33b674ad3292bd6f887 100644 (file)
@@ -11,8 +11,8 @@ PKG_NAME:=samba
 PKG_VERSION:=3.6.25
 PKG_RELEASE:=5
 
 PKG_VERSION:=3.6.25
 PKG_RELEASE:=5
 
-PKG_SOURCE_URL:=http://ftp.samba.org/pub/samba \
-       http://ftp.samba.org/pub/samba/stable
+PKG_SOURCE_URL:=https://download.samba.org/pub/samba \
+               https://download.samba.org/pub/samba/stable
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_HASH:=8f2c8a7f2bd89b0dfd228ed917815852f7c625b2bc0936304ac3ed63aaf83751
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_HASH:=8f2c8a7f2bd89b0dfd228ed917815852f7c625b2bc0936304ac3ed63aaf83751
 
@@ -34,7 +34,7 @@ define Package/samba36-server
   SECTION:=net
   CATEGORY:=Network
   TITLE:=Samba 3.6 SMB/CIFS server
   SECTION:=net
   CATEGORY:=Network
   TITLE:=Samba 3.6 SMB/CIFS server
-  URL:=http://www.samba.org/
+  URL:=https://www.samba.org/
   DEPENDS:=+USE_GLIBC:librt $(ICONV_DEPENDS)
 endef
 
   DEPENDS:=+USE_GLIBC:librt $(ICONV_DEPENDS)
 endef
 
@@ -42,7 +42,7 @@ define Package/samba36-client
   SECTION:=net
   CATEGORY:=Network
   TITLE:=Samba 3.6 SMB/CIFS client
   SECTION:=net
   CATEGORY:=Network
   TITLE:=Samba 3.6 SMB/CIFS client
-  URL:=http://www.samba.org/
+  URL:=https://www.samba.org/
   DEPENDS:=+libreadline +libncurses
 endef
 
   DEPENDS:=+libreadline +libncurses
 endef
 
index c5136a47ae588390466e06e4409faa5b8f60d57d..1ff63e7630de76aa6a655c79011c8ce89c97d3d3 100644 (file)
@@ -11,7 +11,8 @@ PKG_NAME:=ccache
 PKG_VERSION:=3.3.2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_VERSION:=3.3.2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_SOURCE_URL:=http://samba.org/ftp/ccache/
+PKG_SOURCE_URL:=https://download.samba.org/pub/ccache/ \
+               https://samba.org/ftp/ccache/
 PKG_HASH:=907685cb23d8f82074b8d1a9b4ebabb36914d151ac7b96a840c68c08d1a14530
 
 include $(INCLUDE_DIR)/host-build.mk
 PKG_HASH:=907685cb23d8f82074b8d1a9b4ebabb36914d151ac7b96a840c68c08d1a14530
 
 include $(INCLUDE_DIR)/host-build.mk