Port kmod-ipip to the new module layout
authorFlorian Fainelli <florian@openwrt.org>
Mon, 9 Oct 2006 17:18:30 +0000 (17:18 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 9 Oct 2006 17:18:30 +0000 (17:18 +0000)
SVN-Revision: 4991

openwrt/include/modules-2.6.mk
openwrt/package/kernel/modules.mk

index 950ff56786da370fb2f199cb5e286341c8d8f37c..fecaaba6049b18f13f41426df767934bc032200c 100644 (file)
@@ -15,10 +15,6 @@ $(eval $(call KMOD_template,ATM,atm,\
        $(MODULES_DIR)/kernel/drivers/atm/atmtcp.ko \
 ,CONFIG_ATM,,50,atm))
 
        $(MODULES_DIR)/kernel/drivers/atm/atmtcp.ko \
 ,CONFIG_ATM,,50,atm))
 
-$(eval $(call KMOD_template,IPIP,ipip,\
-       $(MODULES_DIR)/kernel/net/ipv4/ipip.ko \
-,CONFIG_NET_IPIP,,60,ipip))
-
 # Block devices
 
 $(eval $(call KMOD_template,LOOP,loop,\
 # Block devices
 
 $(eval $(call KMOD_template,LOOP,loop,\
index 17ad12b350807de4f993dd5609d22313bdab0eae..2ce3ba91edbdab74f5c36adb7e6d3731210723e9 100644 (file)
@@ -303,6 +303,15 @@ define KernelPackage/ebtables
 endef
 $(eval $(call KernelPackage,ebtables))
 
 endef
 $(eval $(call KernelPackage,ebtables))
 
+define KernelPackage/ipip
+  TITLE:=IP in IP encapsulation support
+  DESCRIPTION:=\
+       Kernel modules for IP in IP encapsulation
+  FILES:=$(MODULES_DIR)/kernel/net/ipv4/ipip.$(LINUX_KMOD_SUFFIX)
+  KCONFIG:=$(CONFIG_NET_IPIP)
+endef
+$(eval $(call KernelPackage,ipip))
+
 
 define KernelPackage/ipv6
   TITLE:=IPv6 support
 
 define KernelPackage/ipv6
   TITLE:=IPv6 support