build: fix build dependency of kmod .ipk with version filtered files
authorYousong Zhou <yszhou4tech@gmail.com>
Mon, 17 Dec 2018 13:07:19 +0000 (13:07 +0000)
committerYousong Zhou <yszhou4tech@gmail.com>
Tue, 18 Dec 2018 20:04:17 +0000 (20:04 +0000)
We need to use resolved file list as prerequisites for repacking kmod
.ipk files.  Note that currently version_filter uses a Makefile macro
KERNEL_PATCHVER that should be available at ipk building time.

Reported-by: Rafał Miłecki <zajec5@gmail.com>
Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
include/kernel.mk

index 3861375..19ecf4f 100644 (file)
@@ -259,7 +259,7 @@ $(call KernelPackage/$(1)/config)
   endif
   $$(eval $$(call BuildPackage,kmod-$(1)))
 
-  $$(IPKG_kmod-$(1)): $$(wildcard $$(FILES))
+  $$(IPKG_kmod-$(1)): $$(wildcard $$(call version_filter,$$(FILES)))
 
 endef