libjson-c: Update to 0.12.1
authorDaniel Engberg <daniel.engberg.lists@pyret.net>
Fri, 23 Sep 2016 22:39:47 +0000 (17:39 -0500)
committerJohn Crispin <john@phrozen.org>
Tue, 27 Sep 2016 15:50:21 +0000 (17:50 +0200)
Updates libjson-c and removes backport patch.

Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
package/libs/libjson-c/Makefile
package/libs/libjson-c/patches/001-backport_compile_fix.patch [deleted file]

index 404a55d4175c28d172bd8ad78efa94d3939d5587..51cc645045b2de9eb25dc4467fc693e43d437758 100644 (file)
@@ -8,12 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=json-c
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=json-c
-PKG_VERSION:=0.12
+PKG_VERSION:=0.12.1
 PKG_RELEASE:=1
 
 PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-nodoc.tar.gz
 PKG_SOURCE_URL:=https://s3.amazonaws.com/json-c_releases/releases/
 PKG_SOURCE_URL:=https://s3.amazonaws.com/json-c_releases/releases/
-PKG_MD5SUM:=3ca4bbb881dfc4017e8021b5e0a8c491
+PKG_MD5SUM:=5b91ab230d9b6b0ee20fc19cf25094f5
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_SOURCE_SUBDIR)
 
 PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=COPYING
 
 PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=COPYING
diff --git a/package/libs/libjson-c/patches/001-backport_compile_fix.patch b/package/libs/libjson-c/patches/001-backport_compile_fix.patch
deleted file mode 100644 (file)
index e83f5d2..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
-commit 3859e99f50abe11a8dade28efa9ea3d99dfaac11
-Author: Petar Koretić <petar.koretic@gmail.com>
-Date:   Fri Apr 11 10:03:40 2014 +0200
-
-    Remove unused variable 'size'
-
-diff --git a/json_tokener.c b/json_tokener.c
-index 19de8ef..9a76293 100644
---- a/json_tokener.c
-+++ b/json_tokener.c
-@@ -352,12 +352,10 @@ struct json_object* json_tokener_parse_ex(struct json_tokener *tok,
-     case json_tokener_state_inf: /* aka starts with 'i' */
-       {
--      int size;
-       int size_inf;
-       int is_negative = 0;
-       printbuf_memappend_fast(tok->pb, &c, 1);
--      size = json_min(tok->st_pos+1, json_null_str_len);
-       size_inf = json_min(tok->st_pos+1, json_inf_str_len);
-       char *infbuf = tok->pb->buf;
-       if (*infbuf == '-')