fix uml-2.6 build, move KERNELNAME to kernel-build.mk
authorNicolas Thill <nico@openwrt.org>
Wed, 18 Oct 2006 13:16:44 +0000 (13:16 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 18 Oct 2006 13:16:44 +0000 (13:16 +0000)
SVN-Revision: 5204

include/kernel-build.mk
include/kernel.mk

index 06f4ce77263364c28c8fd6e0933ca44bda925247..a3c714c688b59b743272a50c763eb72e711ecc59 100644 (file)
@@ -18,13 +18,25 @@ KERNEL_IPKG:=$(KERNEL_BUILD_DIR)/kernel_$(LINUX_VERSION)-$(BOARD)-$(LINUX_RELEAS
 TARGETS += $(KERNEL_IPKG)
 INSTALL_TARGETS += $(KERNEL_IPKG)
 
 TARGETS += $(KERNEL_IPKG)
 INSTALL_TARGETS += $(KERNEL_IPKG)
 
-LINUX_KARCH:=$(shell echo $(ARCH) | sed -e 's/i[3-9]86/i386/' \
+ifneq (,$(findstring uml,$(BOARD)))
+  LINUX_KARCH:=um
+else
+  LINUX_KARCH:=$(shell echo $(ARCH) | sed -e 's/i[3-9]86/i386/' \
        -e 's/mipsel/mips/' \
        -e 's/mipseb/mips/' \
        -e 's/powerpc/ppc/' \
        -e 's/sh[234]/sh/' \
        -e 's/armeb/arm/' \
        -e 's/mipsel/mips/' \
        -e 's/mipseb/mips/' \
        -e 's/powerpc/ppc/' \
        -e 's/sh[234]/sh/' \
        -e 's/armeb/arm/' \
-)
+  )
+endif
+
+KERNELNAME=
+ifneq (,$(findstring x86,$(BOARD)))
+  KERNELNAME="bzImage"
+endif
+ifneq (,$(findstring ppc,$(BOARD)))
+  KERNELNAME="uImage"
+endif
 
 
 $(TARGETS): $(PACKAGE_DIR)
 
 
 $(TARGETS): $(PACKAGE_DIR)
index 7c0ba6d7dd7e92afd797c57e80e9f17ca2646096..7a36cee1a5c0ee9bb392bc03c9f6f78607dbe13f 100644 (file)
@@ -31,16 +31,7 @@ else
     LINUX_KMOD_SUFFIX=o
   endif
 
     LINUX_KMOD_SUFFIX=o
   endif
 
-  KERNELNAME=
-  ifneq (,$(findstring x86,$(BOARD)))
-    KERNELNAME="bzImage"
-  endif
-  ifneq (,$(findstring ppc,$(BOARD)))
-    KERNELNAME="uImage"
-  endif
-
   ifneq (,$(findstring uml,$(BOARD)))
   ifneq (,$(findstring uml,$(BOARD)))
-    LINUX_KARCH:=um
     KERNEL_CC:=$(HOSTCC)
     KERNEL_CROSS:=
   else
     KERNEL_CC:=$(HOSTCC)
     KERNEL_CROSS:=
   else