modules: add 6LoWPAN over Bluetooth Low Energy
authorJohn Crispin <john@openwrt.org>
Fri, 23 Jan 2015 12:32:36 +0000 (12:32 +0000)
committerJohn Crispin <john@openwrt.org>
Fri, 23 Jan 2015 12:32:36 +0000 (12:32 +0000)
Adding support 6LoWPAN over Bluetooth Low Energy in kernel 3.18.
Creating new bluetooth_6lowpan group with CONFIG_6LOWPAN and CONFIG_BT_6LOWPAN.
Adding kernel object dependencies for 6LoWPAN over Bluetooth Low Energy.

Signed-off-by: Lukasz Duda <lukasz.duda@nordicsemi.no>
Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 44084

package/kernel/linux/modules/other.mk

index eed258dc22b9a4b52c0f4d0aab2f5f7b3f3c8cc1..70acf547275e6c771aba3454b90aed9a51e5b55d 100644 (file)
@@ -70,6 +70,26 @@ endef
 $(eval $(call KernelPackage,bluetooth))
 
 
+define KernelPackage/bluetooth_6lowpan
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Bluetooth 6LoWPAN support
+  DEPENDS:=+kmod-bluetooth @!(LINUX_3_3||LINUX_3_8||LINUX_3_10||LINUX_3_13||LINUX_3_14)
+  KCONFIG:= \
+  CONFIG_6LOWPAN=m \
+  CONFIG_BT_6LOWPAN=m
+  FILES:= \
+       $(LINUX_DIR)/net/bluetooth/bluetooth_6lowpan.ko \
+       $(LINUX_DIR)/net/6lowpan/6lowpan.ko
+       AUTOLOAD:=$(call AutoProbe,bluetooth)
+endef
+
+define KernelPackage/bluetooth_6lowpan/description
+ Kernel support for 6LoWPAN over Bluetooth Low Energy devices
+endef
+
+$(eval $(call KernelPackage,bluetooth_6lowpan))
+
+
 define KernelPackage/bluetooth-hci-h4p
   SUBMENU:=$(OTHER_MENU)
   TITLE:=HCI driver with H4 Nokia extensions