lantiq: new image build process - fix kernel entry address
authorJohn Crispin <john@openwrt.org>
Tue, 26 Apr 2016 11:43:15 +0000 (11:43 +0000)
committerJohn Crispin <john@openwrt.org>
Tue, 26 Apr 2016 11:43:15 +0000 (11:43 +0000)
Set the kernel entry address to the same value as it is used for the old
image build build process.

Fixes boot of uImages on VGV7510KW22NOR and others.

Signed-off-by: Mathias Kresin <openwrt@kresin.me>
SVN-Revision: 49237

target/linux/lantiq/image/Makefile

index d863a91de4cbfe799a4938a71bccf9ee6e877184..4a358b5123ccb65280c6940b55cbc44e3c9624c7 100644 (file)
@@ -11,7 +11,7 @@
 JFFS2_BLOCKSIZE = 64k 128k 256k
 
 KERNEL_LOADADDR = 0x80002000
-KERNEL_ENTRY = 0x80a00000
+KERNEL_ENTRY = 0x80002000
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk