kernel: Add dummy sound driver
authorJohn Crispin <john@openwrt.org>
Fri, 11 Dec 2015 15:05:53 +0000 (15:05 +0000)
committerJohn Crispin <john@openwrt.org>
Fri, 11 Dec 2015 15:05:53 +0000 (15:05 +0000)
Useful when using sound players that can send to icecast, etc. without any sound device attached.

Signed-off-by: Ted Hess <thess@kitschensync.net>
SVN-Revision: 47852

package/kernel/linux/modules/sound.mk

index 603bb7045cebb67a90567419074c13a7a7c10e80..d09cf21abac30a1353a51ae3269dff023639d1ce 100644 (file)
@@ -273,3 +273,19 @@ define KernelPackage/pcspkr/description
 endef
 
 $(eval $(call KernelPackage,pcspkr))
+
+define KernelPackage/sound-dummy
+  $(call AddDepends/sound)
+  TITLE:=Null sound output driver (sink)
+  KCONFIG:= \
+       CONFIG_SND_DUMMY
+  FILES:= \
+       $(LINUX_DIR)/sound/drivers/snd-dummy.ko
+  AUTOLOAD:=$(call AutoLoad,32,snd-dummy)
+endef
+
+define KernelPackage/sound_dummy/description
+ Dummy sound device for Alsa when no hardware present
+endef
+
+$(eval $(call KernelPackage,sound-dummy))