kernel: make kmod-crypto-rng depend on kmod-crypto-hash
authorFelix Fietkau <nbd@openwrt.org>
Sat, 12 Dec 2015 12:02:20 +0000 (12:02 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 12 Dec 2015 12:02:20 +0000 (12:02 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 47883

package/kernel/linux/modules/crypto.mk

index dc817eed5fe767f3a40b2569ac355029b144466c..604be9fce9b6e268dbe8bd80ddab227ff0398a6d 100644 (file)
@@ -100,6 +100,7 @@ $(eval $(call KernelPackage,crypto-wq))
 
 define KernelPackage/crypto-rng
   TITLE:=CryptoAPI random number generation
+  DEPENDS:=+kmod-crypto-hash
   KCONFIG:= \
        CONFIG_CRYPTO_DRBG \
        CONFIG_CRYPTO_JITTERENTROPY \