wireguard: no longer need portability patch
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Thu, 17 May 2018 22:08:21 +0000 (23:08 +0100)
committerJohn Crispin <john@phrozen.org>
Fri, 18 May 2018 09:19:00 +0000 (11:19 +0200)
Drop package/network/services/wireguard/patches/100-portability.patch

Instead pass 'PLATFORM=linux' to make since we are always building FOR
linux.

Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
package/network/services/wireguard/Makefile
package/network/services/wireguard/patches/100-portability.patch [deleted file]

index 5ca7b7da57875be022e2fdd38bf48061e8b8a17d..770efe4948dc837e09233e616978b7bfeeba3bf4 100644 (file)
@@ -60,6 +60,7 @@ include $(INCLUDE_DIR)/package-defaults.mk
 
 # Used by Build/Compile/Default
 MAKE_PATH:=src/tools
 
 # Used by Build/Compile/Default
 MAKE_PATH:=src/tools
+MAKE_VARS += PLATFORM=linux
 
 define Build/Compile
        $(MAKE) $(KERNEL_MAKEOPTS) M="$(PKG_BUILD_DIR)/src" modules
 
 define Build/Compile
        $(MAKE) $(KERNEL_MAKEOPTS) M="$(PKG_BUILD_DIR)/src" modules
diff --git a/package/network/services/wireguard/patches/100-portability.patch b/package/network/services/wireguard/patches/100-portability.patch
deleted file mode 100644 (file)
index 33a7373..0000000
+++ /dev/null
@@ -1,19 +0,0 @@
-tools: fix portability issue
-
-Check if the compiler defines __linux__, instead of assuming that the
-host OS is the same as the target OS.
-
-Signed-off-by: Felix Fietkau <nbd@nbd.name>
----
---- a/src/tools/Makefile
-+++ b/src/tools/Makefile
-@@ -36,6 +36,9 @@ endif
- endif
- PLATFORM ?= $(shell uname -s | tr '[:upper:]' '[:lower:]')
-+ifeq ($(strip $(shell echo __linux__ | $(CC) -E - | grep -v '^\#')),1)
-+PLATFORM := linux
-+endif
- CFLAGS ?= -O3
- CFLAGS += -std=gnu11 -D_GNU_SOURCE