allow configuration of the target directory for binaries
authorImre Kaloz <kaloz@openwrt.org>
Fri, 22 Nov 2013 09:39:41 +0000 (09:39 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Fri, 22 Nov 2013 09:39:41 +0000 (09:39 +0000)
Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
SVN-Revision: 38890

Config.in
rules.mk

index 4f7667aa1fd116560ae14db67d483f8ec4b689f8..bf1e139f2e666d4b1de31a76ecf846c1f233b019 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -421,6 +421,10 @@ menuconfig DEVEL
                bool "Show broken platforms / packages" if DEVEL
                default n
 
+       config BINARY_FOLDER
+               string "Binary folder" if DEVEL
+               default ""
+
        config DOWNLOAD_FOLDER
                string "Download folder" if DEVEL
                default ""
index a3efb7db4f297783c0eed2f487e6c1a6b17e5303..80e07d11a20597d91ddb62d218350a61d87858db 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -73,7 +73,7 @@ ifdef CONFIG_MIPS64_ABI
 endif
 
 DL_DIR:=$(if $(call qstrip,$(CONFIG_DOWNLOAD_FOLDER)),$(call qstrip,$(CONFIG_DOWNLOAD_FOLDER)),$(TOPDIR)/dl)
-BIN_DIR:=$(TOPDIR)/bin/$(BOARD)
+BIN_DIR:=$(if $(call qstrip,$(CONFIG_BINARY_FOLDER)),$(call qstrip,$(CONFIG_BINARY_FOLDER)),$(TOPDIR)/bin/$(BOARD))
 INCLUDE_DIR:=$(TOPDIR)/include
 SCRIPT_DIR:=$(TOPDIR)/scripts
 BUILD_DIR_BASE:=$(TOPDIR)/build_dir