build: define check-kernel-size to remove unflashable images
authorJeff Kletsky <git-commits@allycomm.com>
Wed, 13 Nov 2019 21:09:48 +0000 (13:09 -0800)
committerJohn Crispin <john@phrozen.org>
Wed, 15 Jan 2020 19:05:48 +0000 (20:05 +0100)
Certain boards have limitations on U-Boot that prevent flashing
of images where the kernel size exceeds a threshold, yet
sysupgrade can sucessfully manage larger kernels. The current
check-size will remove the target artifact if its total size
exceeds the threshold. If applied after append-kernel,
it will remove the kernel, but the remaining image-assembly
steps will continue, resulting in an image without a kernel
that is likely unbootable.

By defining check-kernel-size, it is now possible to prevent release
of such unbootable images through a construct similar to:

  IMAGE/factory.img := append-kernel | pad-to $$$$(GL_UBOOT_UBI_OFFSET) | \
    append-ubi | check-kernel-size $$$$(GL_UBOOT_UBI_OFFSET)

Cc: Chuanhong Guo <gch981213@gmail.com>
Signed-off-by: Jeff Kletsky <git-commits@allycomm.com>
include/image-commands.mk

index 3b091f26aca1e39482639015471531c44cfd921a..37cb083bbfbca2c6c62305f20d3840ddc476eb1f 100644 (file)
@@ -275,6 +275,13 @@ define Build/check-size
        }
 endef
 
+define Build/check-kernel-size
+       @[ $$(($(subst k,* 1024,$(subst m, * 1024k,$(1))))) -ge "$$(stat -c%s $(IMAGE_KERNEL))" ] || { \
+               echo "WARNING: Kernel for $@ is too big > $(1)" >&2; \
+               rm -f $@; \
+       }
+endef
+
 define Build/combined-image
        -sh $(TOPDIR)/scripts/combined-image.sh \
                "$(IMAGE_KERNEL)" \