bcm53xx: use final (backported) patch fixing serial console
authorRafał Miłecki <zajec5@gmail.com>
Tue, 20 Jan 2015 08:04:27 +0000 (08:04 +0000)
committerRafał Miłecki <zajec5@gmail.com>
Tue, 20 Jan 2015 08:04:27 +0000 (08:04 +0000)
Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
SVN-Revision: 44059

target/linux/bcm53xx/patches-3.14/001-mtd-spi-nor.patch
target/linux/bcm53xx/patches-3.14/044-0-ARM-BCM5301X-fix-early-serial-console.patch [new file with mode: 0644]
target/linux/bcm53xx/patches-3.14/052-ARM-BCM5301X-Add-DT-for-Luxul-XWC-1000.patch
target/linux/bcm53xx/patches-3.14/301-ARM-BCM5301X-fix-early-serial-console.patch [deleted file]
target/linux/bcm53xx/patches-3.18/043-ARM-BCM5301X-fix-early-serial-console.patch [new file with mode: 0644]
target/linux/bcm53xx/patches-3.18/052-ARM-BCM5301X-Add-DT-for-Luxul-XWC-1000.patch
target/linux/bcm53xx/patches-3.18/110-firmware-backport-NVRAM-driver.patch
target/linux/bcm53xx/patches-3.18/301-ARM-BCM5301X-fix-early-serial-console.patch [deleted file]

index f14de337da5e569abbcde6418f8c5ffaf53ec323..8b6ed43f9872657ff623162543bbc7d3d9d3720a 100644 (file)
@@ -3,7 +3,7 @@ This patch does not contain any further code not in this mainline kernel.
 
 --- a/drivers/mtd/Kconfig
 +++ b/drivers/mtd/Kconfig
-@@ -371,6 +371,8 @@ source "drivers/mtd/onenand/Kconfig"
+@@ -366,6 +366,8 @@ source "drivers/mtd/onenand/Kconfig"
  
  source "drivers/mtd/lpddr/Kconfig"
  
@@ -14,7 +14,7 @@ This patch does not contain any further code not in this mainline kernel.
  endif # MTD
 --- a/drivers/mtd/Makefile
 +++ b/drivers/mtd/Makefile
-@@ -39,4 +39,5 @@ inftl-objs           := inftlcore.o inftlmount.o
+@@ -35,4 +35,5 @@ inftl-objs           := inftlcore.o inftlmount.o
  
  obj-y         += chips/ lpddr/ maps/ devices/ nand/ onenand/ tests/
  
diff --git a/target/linux/bcm53xx/patches-3.14/044-0-ARM-BCM5301X-fix-early-serial-console.patch b/target/linux/bcm53xx/patches-3.14/044-0-ARM-BCM5301X-fix-early-serial-console.patch
new file mode 100644 (file)
index 0000000..4ead8c4
--- /dev/null
@@ -0,0 +1,39 @@
+From 140bd60383309e82b5cae3294a907c11a0a12b90 Mon Sep 17 00:00:00 2001
+From: Hauke Mehrtens <hauke@hauke-m.de>
+Date: Sun, 14 Sep 2014 21:43:40 +0200
+Subject: [PATCH] ARM: BCM5301X: fix early serial console
+
+This device actually has a 8250 serial with a shift of 0.
+Tested this on a BCM4708.
+
+Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
+Signed-off-by: Arnd Bergmann <arnd@arndb.de>
+---
+ arch/arm/Kconfig.debug | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/arch/arm/Kconfig.debug b/arch/arm/Kconfig.debug
+index 1c4889d..a528843 100644
+--- a/arch/arm/Kconfig.debug
++++ b/arch/arm/Kconfig.debug
+@@ -109,7 +109,7 @@ choice
+       config DEBUG_BCM_5301X
+               bool "Kernel low-level debugging on BCM5301X UART1"
+               depends on ARCH_BCM_5301X
+-              select DEBUG_UART_PL01X
++              select DEBUG_UART_8250
+       config DEBUG_BCM_KONA_UART
+               bool "Kernel low-level debugging messages via BCM KONA UART"
+@@ -1132,7 +1132,7 @@ config DEBUG_UART_VIRT
+ config DEBUG_UART_8250_SHIFT
+       int "Register offset shift for the 8250 debug UART"
+       depends on DEBUG_LL_UART_8250 || DEBUG_UART_8250
+-      default 0 if FOOTBRIDGE || ARCH_IOP32X
++      default 0 if FOOTBRIDGE || ARCH_IOP32X || DEBUG_BCM_5301X
+       default 2
+ config DEBUG_UART_8250_WORD
+-- 
+1.8.4.5
+
index daa641f20fc11aef17089d0bfab0652b220fecfa..f0aafa91645618829dc640b23417f6871be4ac31 100644 (file)
@@ -18,8 +18,8 @@ diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
 index 91bd5bd..ff4a5ae 100644
 --- a/arch/arm/boot/dts/Makefile
 +++ b/arch/arm/boot/dts/Makefile
-@@ -57,6 +57,7 @@ dtb-$(CONFIG_ARCH_BCM2835) += bcm2835-rpi-b.dtb
- dtb-$(CONFIG_ARCH_BCM2835) += bcm2835-rpi-b-plus.dtb
+@@ -52,6 +52,7 @@ dtb-$(CONFIG_ARCH_BCM_MOBILE) += bcm1135
+ dtb-$(CONFIG_ARCH_BCM2835) += bcm2835-rpi-b.dtb
  dtb-$(CONFIG_ARCH_BCM_5301X) += \
        bcm4708-buffalo-wzr-1750dhp.dtb \
 +      bcm4708-luxul-xwc-1000.dtb \
diff --git a/target/linux/bcm53xx/patches-3.14/301-ARM-BCM5301X-fix-early-serial-console.patch b/target/linux/bcm53xx/patches-3.14/301-ARM-BCM5301X-fix-early-serial-console.patch
deleted file mode 100644 (file)
index 5c6f6ec..0000000
+++ /dev/null
@@ -1,33 +0,0 @@
-From 310a267714f7565dba8934dd51cdead6adc3b630 Mon Sep 17 00:00:00 2001
-From: Hauke Mehrtens <hauke@hauke-m.de>
-Date: Sun, 14 Sep 2014 21:02:35 +0200
-Subject: [PATCH 4/4] ARM: BCM5301X: fix early serial console
-
-This device actually has a 8250 serial with a shift of 0.
-Tested this on a BCM4708.
-
-Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
----
- arch/arm/Kconfig.debug | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
---- a/arch/arm/Kconfig.debug
-+++ b/arch/arm/Kconfig.debug
-@@ -109,7 +109,7 @@ choice
-       config DEBUG_BCM_5301X
-               bool "Kernel low-level debugging on BCM5301X UART1"
-               depends on ARCH_BCM_5301X
--              select DEBUG_UART_PL01X
-+              select DEBUG_UART_8250
-       config DEBUG_BCM_KONA_UART
-               bool "Kernel low-level debugging messages via BCM KONA UART"
-@@ -1132,7 +1132,7 @@ config DEBUG_UART_VIRT
- config DEBUG_UART_8250_SHIFT
-       int "Register offset shift for the 8250 debug UART"
-       depends on DEBUG_LL_UART_8250 || DEBUG_UART_8250
--      default 0 if FOOTBRIDGE || ARCH_IOP32X
-+      default 0 if FOOTBRIDGE || ARCH_IOP32X || DEBUG_BCM_5301X
-       default 2
- config DEBUG_UART_8250_WORD
diff --git a/target/linux/bcm53xx/patches-3.18/043-ARM-BCM5301X-fix-early-serial-console.patch b/target/linux/bcm53xx/patches-3.18/043-ARM-BCM5301X-fix-early-serial-console.patch
new file mode 100644 (file)
index 0000000..517b2e7
--- /dev/null
@@ -0,0 +1,39 @@
+From 140bd60383309e82b5cae3294a907c11a0a12b90 Mon Sep 17 00:00:00 2001
+From: Hauke Mehrtens <hauke@hauke-m.de>
+Date: Sun, 14 Sep 2014 21:43:40 +0200
+Subject: [PATCH] ARM: BCM5301X: fix early serial console
+
+This device actually has a 8250 serial with a shift of 0.
+Tested this on a BCM4708.
+
+Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
+Signed-off-by: Arnd Bergmann <arnd@arndb.de>
+---
+ arch/arm/Kconfig.debug | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/arch/arm/Kconfig.debug b/arch/arm/Kconfig.debug
+index 1c4889d..a528843 100644
+--- a/arch/arm/Kconfig.debug
++++ b/arch/arm/Kconfig.debug
+@@ -113,7 +113,7 @@ choice
+       config DEBUG_BCM_5301X
+               bool "Kernel low-level debugging on BCM5301X UART1"
+               depends on ARCH_BCM_5301X
+-              select DEBUG_UART_PL01X
++              select DEBUG_UART_8250
+       config DEBUG_BCM_KONA_UART
+               bool "Kernel low-level debugging messages via BCM KONA UART"
+@@ -1249,7 +1249,7 @@ config DEBUG_UART_VIRT
+ config DEBUG_UART_8250_SHIFT
+       int "Register offset shift for the 8250 debug UART"
+       depends on DEBUG_LL_UART_8250 || DEBUG_UART_8250
+-      default 0 if FOOTBRIDGE || ARCH_IOP32X
++      default 0 if FOOTBRIDGE || ARCH_IOP32X || DEBUG_BCM_5301X
+       default 2
+ config DEBUG_UART_8250_WORD
+-- 
+1.8.4.5
+
index daa641f20fc11aef17089d0bfab0652b220fecfa..c9cf71b70f3c565af1fc00306e3251008fdc6d99 100644 (file)
@@ -18,8 +18,8 @@ diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
 index 91bd5bd..ff4a5ae 100644
 --- a/arch/arm/boot/dts/Makefile
 +++ b/arch/arm/boot/dts/Makefile
-@@ -57,6 +57,7 @@ dtb-$(CONFIG_ARCH_BCM2835) += bcm2835-rpi-b.dtb
- dtb-$(CONFIG_ARCH_BCM2835) += bcm2835-rpi-b-plus.dtb
+@@ -56,6 +56,7 @@ dtb-$(CONFIG_ARCH_AXXIA) += axm5516-amar
+ dtb-$(CONFIG_ARCH_BCM2835) += bcm2835-rpi-b.dtb
  dtb-$(CONFIG_ARCH_BCM_5301X) += \
        bcm4708-buffalo-wzr-1750dhp.dtb \
 +      bcm4708-luxul-xwc-1000.dtb \
index 5c460f1ad9cbee4cfb1d129114facdc8f49d3493..d9bbc3972c9fa6fa7f5647bfad9caea286ef799e 100644 (file)
@@ -21,7 +21,7 @@ diff --git a/arch/arm/Kconfig b/arch/arm/Kconfig
 index 4733d32..ab18030 100644
 --- a/arch/arm/Kconfig
 +++ b/arch/arm/Kconfig
-@@ -2286,6 +2286,8 @@ source "net/Kconfig"
+@@ -2166,6 +2166,8 @@ source "net/Kconfig"
  
  source "drivers/Kconfig"
  
diff --git a/target/linux/bcm53xx/patches-3.18/301-ARM-BCM5301X-fix-early-serial-console.patch b/target/linux/bcm53xx/patches-3.18/301-ARM-BCM5301X-fix-early-serial-console.patch
deleted file mode 100644 (file)
index 4d100da..0000000
+++ /dev/null
@@ -1,33 +0,0 @@
-From 310a267714f7565dba8934dd51cdead6adc3b630 Mon Sep 17 00:00:00 2001
-From: Hauke Mehrtens <hauke@hauke-m.de>
-Date: Sun, 14 Sep 2014 21:02:35 +0200
-Subject: [PATCH 4/4] ARM: BCM5301X: fix early serial console
-
-This device actually has a 8250 serial with a shift of 0.
-Tested this on a BCM4708.
-
-Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
----
- arch/arm/Kconfig.debug | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
---- a/arch/arm/Kconfig.debug
-+++ b/arch/arm/Kconfig.debug
-@@ -113,7 +113,7 @@ choice
-       config DEBUG_BCM_5301X
-               bool "Kernel low-level debugging on BCM5301X UART1"
-               depends on ARCH_BCM_5301X
--              select DEBUG_UART_PL01X
-+              select DEBUG_UART_8250
-       config DEBUG_BCM_KONA_UART
-               bool "Kernel low-level debugging messages via BCM KONA UART"
-@@ -1249,7 +1249,7 @@ config DEBUG_UART_VIRT
- config DEBUG_UART_8250_SHIFT
-       int "Register offset shift for the 8250 debug UART"
-       depends on DEBUG_LL_UART_8250 || DEBUG_UART_8250
--      default 0 if FOOTBRIDGE || ARCH_IOP32X
-+      default 0 if FOOTBRIDGE || ARCH_IOP32X || DEBUG_BCM_5301X
-       default 2
- config DEBUG_UART_8250_WORD