mkimage: update to 2014.07
authorLuka Perkov <luka@openwrt.org>
Fri, 8 Aug 2014 21:03:14 +0000 (21:03 +0000)
committerLuka Perkov <luka@openwrt.org>
Fri, 8 Aug 2014 21:03:14 +0000 (21:03 +0000)
Signed-off-by: Luka Perkov <luka@openwrt.org>
SVN-Revision: 42082

tools/mkimage/Makefile
tools/mkimage/patches/010-freebsd-ulong-fix.patch
tools/mkimage/patches/040-include_order.patch
tools/mkimage/patches/050-image_h_portability.patch

index 47e918a5a22d2936562f7801251cb6f1a6a2b1c4..49eb26184d81daffe698086e35b2f46106b5ca65 100644 (file)
@@ -7,11 +7,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mkimage
-PKG_VERSION:=2014.04
+PKG_VERSION:=2014.07
 
 PKG_SOURCE:=u-boot-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=ftp://ftp.denx.de/pub/u-boot
-PKG_MD5SUM:=6d2116d1385a66e9a59742caa9d62a54
+PKG_MD5SUM:=36d4bad687edcafa396fee607e505d4e
 PKG_CAT:=bzcat
 
 HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/u-boot-$(PKG_VERSION)
index 154346d8be80d39e9911b17b58bdaf97a1b5cdd9..75b9e892ad03664a597d0d46b1c824c6f76adbfc 100644 (file)
@@ -9,5 +9,5 @@
 +#endif
 +
  #if defined(CONFIG_FIT)
+ #include <hash.h>
  #include <libfdt.h>
- #include <fdt_support.h>
index f4fbbaf7578d1db1e3ee4137d3dedb1ea5e5c6cd..66f703c85554c0882113569a4d2aee9da24a90ae 100644 (file)
@@ -1,6 +1,6 @@
 --- a/tools/Makefile
 +++ b/tools/Makefile
-@@ -173,7 +173,7 @@
+@@ -193,7 +193,7 @@
  # Define _GNU_SOURCE to obtain the getline prototype from stdio.h
  #
  HOST_EXTRACFLAGS += -include $(srctree)/include/libfdt_env.h \
index 767a8b8713c41de64d2ec4b403ffbd78307c48d9..304a7aa24765d45229a3a05bd96e1dcf3916b0bb 100644 (file)
@@ -8,7 +8,7 @@
  
  /* Define this to avoid #ifdefs later on */
  struct lmb;
-@@ -240,13 +239,13 @@
+@@ -257,13 +256,13 @@
   * all data in network byte order (aka natural aka bigendian).
   */
  typedef struct image_header {