lantiq: clean up target/subtarget features
authorRui Salvaterra <rsalvaterra@gmail.com>
Wed, 25 Nov 2020 09:38:51 +0000 (09:38 +0000)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Wed, 25 Nov 2020 12:23:06 +0000 (13:23 +0100)
The feature "squashfs" is defined for target and all subtargets
individually. Remove the redundant entries in the subtargets.

Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
[split patch, adjust commit title/message]
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/lantiq/ase/target.mk
target/linux/lantiq/falcon/target.mk
target/linux/lantiq/xrx200/target.mk
target/linux/lantiq/xway/target.mk
target/linux/lantiq/xway_legacy/target.mk

index 5f6c03b38e09776e9704e6f0d39ee9a9e7626809..82a162bbb1e04934ea2432d85b17c41dad0956f0 100644 (file)
@@ -7,7 +7,7 @@
 ARCH:=mips
 SUBTARGET:=ase
 BOARDNAME:=Amazon-SE
-FEATURES:=squashfs atm mips16 small_flash
+FEATURES:=atm mips16 small_flash
 CPU_TYPE:=mips32
 
 DEFAULT_PACKAGES+=kmod-leds-gpio kmod-gpio-button-hotplug \
index 3c848dfda7f64cd54e8e79b6ae424466daac4751..ddab1988492058913db64518068bc2bcff506085 100644 (file)
@@ -1,7 +1,7 @@
 ARCH:=mips
 SUBTARGET:=falcon
 BOARDNAME:=Falcon
-FEATURES:=squashfs nand
+FEATURES:=nand
 CPU_TYPE:=24kc
 
 DEFAULT_PACKAGES+= kmod-leds-gpio \
index 4d92b25bcb8ccdf211ad036c4cfa583b92ae0dec..8497db51ba0e240a9984f538dfd4059f80044d6d 100644 (file)
@@ -1,7 +1,7 @@
 ARCH:=mips
 SUBTARGET:=xrx200
 BOARDNAME:=XRX200
-FEATURES:=squashfs atm nand ramdisk
+FEATURES:=atm nand ramdisk
 CPU_TYPE:=24kc
 
 DEFAULT_PACKAGES+=kmod-leds-gpio \
index 550c61edf0d7a367fba8d0fd01dd000574276839..9ad240e8ca4f95f371403f24eaf2397cd07c7a09 100644 (file)
@@ -1,7 +1,7 @@
 ARCH:=mips
 SUBTARGET:=xway
 BOARDNAME:=XWAY
-FEATURES:=squashfs atm nand ramdisk
+FEATURES:=atm nand ramdisk
 CPU_TYPE:=24kc
 
 DEFAULT_PACKAGES+=kmod-leds-gpio kmod-gpio-button-hotplug swconfig
index 7678030ead3a955bdde7cedd9633ce7d9abb25d6..641c590d48c7f1958071da21543d6b797b0ea8c0 100644 (file)
@@ -1,7 +1,7 @@
 ARCH:=mips
 SUBTARGET:=xway_legacy
 BOARDNAME:=XWAY Legacy
-FEATURES:=squashfs atm ramdisk small_flash
+FEATURES:=atm ramdisk small_flash
 CPU_TYPE:=24kc
 
 DEFAULT_PACKAGES+=kmod-leds-gpio kmod-gpio-button-hotplug swconfig