use gcc 4.1.1 for 2.6, 3.4.6 for 2.4 targets by default
authorImre Kaloz <kaloz@openwrt.org>
Fri, 26 Jan 2007 10:55:06 +0000 (10:55 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Fri, 26 Jan 2007 10:55:06 +0000 (10:55 +0000)
SVN-Revision: 6208

toolchain/gcc/Config.in
toolchain/gcc/Config.version

index 55ab7e5..e5ee5bd 100644 (file)
@@ -2,8 +2,8 @@
 
 choice
        prompt "GCC compiler Version" if TOOLCHAINOPTS
-       default GCC_VERSION_4_1_1 if LINUX_2_6_ARUBA
-       default GCC_VERSION_3_4_6
+       default GCC_VERSION_4_1_1
+       default GCC_VERSION_3_4_6 if LINUX_2_4
        help
          Select the version of gcc you wish to use.
 
index 397dfa4..495c883 100644 (file)
@@ -9,14 +9,14 @@ config GCC_VERSION
        default "4.1.1"     if GCC_VERSION_4_1_1
        default "4.2"           if GCC_VERSION_4_2
        default "3.4.6-nonmips"     if GCC_VERSION_3_4_6_nonmips
-       default "3.4.6"
+       default "4.1.1"
 
 if !TOOLCHAINOPTS
        config GCC_VERSION_4_2
                default n
 
-       config GCC_VERSION_4_1_1
-               default y if LINUX_2_6_ARUBA || LINUX_2_6_IXP4XX || LINUX_2_6_RB532 || LINUX_2_6_X86
+       config GCC_VERSION_3_4_6
+               default y if LINUX_2_4
 endif