kernel: bump 4.19 to 4.19.36
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 22 Apr 2019 19:52:42 +0000 (21:52 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 23 Apr 2019 11:22:31 +0000 (13:22 +0200)
Refreshed all patches.

Compile-tested on: cns3xxx, imx6
Runtime-tested on: cns3xxx, imx6

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/hack-4.19/902-debloat_proc.patch
target/linux/generic/pending-4.19/332-arc-add-OWRTDTB-section.patch

index 3b11d3ecb6532832a8ded2441d4ab88ab9eb2d15..c1882627e4ab7a64ae04c609b16a5658c5458fd4 100644 (file)
@@ -5,12 +5,12 @@ LINUX_RELEASE?=1
 LINUX_VERSION-3.18 = .136
 LINUX_VERSION-4.9 = .170
 LINUX_VERSION-4.14 = .113
 LINUX_VERSION-3.18 = .136
 LINUX_VERSION-4.9 = .170
 LINUX_VERSION-4.14 = .113
-LINUX_VERSION-4.19 = .35
+LINUX_VERSION-4.19 = .36
 
 LINUX_KERNEL_HASH-3.18.136 = 48c8775013d23229462134f911bbb14c7935096fcccfb19ce28ecd5f7154f35c
 LINUX_KERNEL_HASH-4.9.170 = 33887b40fc8e0b71f423bb7afe112a4ae190378145f4a3f3892c563b7e43131d
 LINUX_KERNEL_HASH-4.14.113 = b24df2e37faaf2290999c507f9e29de98494f52429bcd35513c5b3e52eaddac2
 
 LINUX_KERNEL_HASH-3.18.136 = 48c8775013d23229462134f911bbb14c7935096fcccfb19ce28ecd5f7154f35c
 LINUX_KERNEL_HASH-4.9.170 = 33887b40fc8e0b71f423bb7afe112a4ae190378145f4a3f3892c563b7e43131d
 LINUX_KERNEL_HASH-4.14.113 = b24df2e37faaf2290999c507f9e29de98494f52429bcd35513c5b3e52eaddac2
-LINUX_KERNEL_HASH-4.19.35 = 2fa7e560f0e020104c6e09ffb6c2242a8f5c4b5c39e41ed2996fa7b8b42047e0
+LINUX_KERNEL_HASH-4.19.36 = b808b508177f9d288d94a3b9df7b01d5eac9fcc1804a794c913b2144de63f2bc
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index bf633d5ece8254d423cfbd1e5538fb431e9adef8..19538458d93cbdd056603944121c8dff9a136064 100644 (file)
@@ -243,7 +243,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
                                &vmalloc_op,
 --- a/mm/vmstat.c
 +++ b/mm/vmstat.c
                                &vmalloc_op,
 --- a/mm/vmstat.c
 +++ b/mm/vmstat.c
-@@ -1972,10 +1972,12 @@ void __init init_mm_internals(void)
+@@ -1976,10 +1976,12 @@ void __init init_mm_internals(void)
        start_shepherd_timer();
  #endif
  #ifdef CONFIG_PROC_FS
        start_shepherd_timer();
  #endif
  #ifdef CONFIG_PROC_FS
index 7927ea42428ccf1d8d9ce53db6fc8bde90426f57..6fea6f0b666e361244cb77923b190bfdd2f3c11a 100644 (file)
@@ -42,7 +42,7 @@ Signed-off-by: Evgeniy Didin <Evgeniy.Didin@synopsys.com>
  ;----------------------------------------------------------------
 --- a/arch/arc/kernel/setup.c
 +++ b/arch/arc/kernel/setup.c
  ;----------------------------------------------------------------
 --- a/arch/arc/kernel/setup.c
 +++ b/arch/arc/kernel/setup.c
-@@ -520,7 +520,7 @@ ignore_uboot_args:
+@@ -528,7 +528,7 @@ ignore_uboot_args:
  #endif
  
        if (use_embedded_dtb) {
  #endif
  
        if (use_embedded_dtb) {
@@ -51,7 +51,7 @@ Signed-off-by: Evgeniy Didin <Evgeniy.Didin@synopsys.com>
                if (!machine_desc)
                        panic("Embedded DT invalid\n");
        }
                if (!machine_desc)
                        panic("Embedded DT invalid\n");
        }
-@@ -536,6 +536,8 @@ ignore_uboot_args:
+@@ -544,6 +544,8 @@ ignore_uboot_args:
        }
  }
  
        }
  }