base-files: add hotplug rules for /dev/lpX (#863)
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 28 Sep 2009 20:05:50 +0000 (20:05 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 28 Sep 2009 20:05:50 +0000 (20:05 +0000)
SVN-Revision: 17792

package/base-files/Makefile
package/base-files/files/etc/hotplug2-common.rules

index b0dc94ebe6649c695397a7321bcf4ceb0b8b9a4e..b288c0dfce2bbfe34636e838b138c79f2677c119 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=31
+PKG_RELEASE:=32
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 
index 3a9f4c5ded136e06b23471793e82890d22c1776a..d6dd6e8a9b3f50a92f42c99bde1279f12962d537 100644 (file)
@@ -23,6 +23,12 @@ DEVICENAME ~~ (controlC[0-9]|pcmC0D0*|timer) {
        next
 }
 
+DEVICENAME ~~ (lp[0-9]) {
+       nothrottle
+       makedev /dev/%DEVICENAME% 0644
+       next
+}
+
 DEVPATH is set, SUBSYSTEM ~~ (input) {
        nothrottle
        makedev /dev/input/%DEVICENAME% 0644