iproute2: install netlink header and library
authorNicolas Thill <nico@openwrt.org>
Tue, 26 May 2009 21:58:24 +0000 (21:58 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 26 May 2009 21:58:24 +0000 (21:58 +0000)
SVN-Revision: 16100

package/iproute2/Makefile

index 4fd34f20bb1c2cde9ba040f38fcc321f803f82c9..a5d90f5a58b6a209100f338451cfac12a0a8f72e 100644 (file)
@@ -57,6 +57,13 @@ define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) $(TARGET_CONFIGURE_OPTS) KERNEL_INCLUDE=$(LINUX_DIR)/include all tc/tc ip/ip
 endef
 
        $(MAKE) -C $(PKG_BUILD_DIR) $(TARGET_CONFIGURE_OPTS) KERNEL_INCLUDE=$(LINUX_DIR)/include all tc/tc ip/ip
 endef
 
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_BUILD_DIR)/include/libnetlink.h $(1)/usr/include/
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_BUILD_DIR)/lib/libnetlink.a $(1)/usr/lib/
+endef
+
 define Package/ip/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_DIR) $(1)/etc/iproute2
 define Package/ip/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_DIR) $(1)/etc/iproute2