kernel: bump 5.4 to 5.4.129
authorJohn Audia <graysky@archlinux.us>
Wed, 30 Jun 2021 20:57:44 +0000 (16:57 -0400)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 17 Jul 2021 11:21:03 +0000 (13:21 +0200)
All patches automatically rebased.

Build system: x86_64
Build-tested: ipq806x/R7800
Run-tested: ipq806x/R7800

No dmesg regressions, everything functional

Signed-off-by: John Audia <graysky@archlinux.us>
include/kernel-version.mk
target/linux/bcm27xx/patches-5.4/950-0297-arch-arm-Add-model-string-to-cpuinfo.patch
target/linux/generic/hack-5.4/204-module_strip.patch
target/linux/generic/pending-5.4/203-kallsyms_uncompressed.patch
target/linux/generic/pending-5.4/630-packet_socket_type.patch
target/linux/generic/pending-5.4/920-mangle_bootargs.patch
target/linux/layerscape/patches-5.4/817-spi-0003-MLK-21960-1-spi-fspi-enable-fspi-on-imx8qxp-and-imx8.patch
target/linux/layerscape/patches-5.4/817-spi-0004-MLK-21960-2-spi-fspi-dynamically-alloc-AHB-memory.patch

index daa1a5efa835e04dfcd7bdd6aeec6ea7c03620e8..b0611454b17a83bab438d8600b72cfd680c6ddfc 100644 (file)
@@ -6,10 +6,10 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-5.4 = .128
+LINUX_VERSION-5.4 = .129
 LINUX_VERSION-5.10 = .46
 
-LINUX_KERNEL_HASH-5.4.128 = 3b54aebb816b9e628cb9ba3055a6aca58ce0ddeec49366c0da86ced9a7be39ab
+LINUX_KERNEL_HASH-5.4.129 = 4426462413d174909a1d9938ce420b8b3cb219140d164270ccabd282fa2346df
 LINUX_KERNEL_HASH-5.10.46 = 569122a39c6b325befb9ac1c07da0c53e6363b3baacd82081d131b06c1dc1415
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 4e9598a54ee822f023c9580309fd63ef58032af3..e3cf7bb9e1703f05b2b71d77b15c284be80240f4 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
 
 --- a/arch/arm/kernel/setup.c
 +++ b/arch/arm/kernel/setup.c
-@@ -1249,6 +1249,8 @@ static int c_show(struct seq_file *m, vo
+@@ -1251,6 +1251,8 @@ static int c_show(struct seq_file *m, vo
  {
        int i, j;
        u32 cpuid;
@@ -19,7 +19,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
  
        for_each_online_cpu(i) {
                /*
-@@ -1308,6 +1310,14 @@ static int c_show(struct seq_file *m, vo
+@@ -1310,6 +1312,14 @@ static int c_show(struct seq_file *m, vo
        seq_printf(m, "Revision\t: %04x\n", system_rev);
        seq_printf(m, "Serial\t\t: %s\n", system_serial);
  
index 22bb1ac33af8f4676df52c54cef28c41416d32e6..c6420739c07e4bd239b6ebad547c6dff0c735f09 100644 (file)
@@ -96,7 +96,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
 --- a/init/Kconfig
 +++ b/init/Kconfig
-@@ -2195,6 +2195,13 @@ config TRIM_UNUSED_KSYMS
+@@ -2198,6 +2198,13 @@ config TRIM_UNUSED_KSYMS
  
          If unsure, or if you need to build out-of-tree modules, say N.
  
@@ -112,7 +112,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  config MODULES_TREE_LOOKUP
 --- a/kernel/module.c
 +++ b/kernel/module.c
-@@ -3252,9 +3252,11 @@ static int setup_load_info(struct load_i
+@@ -3256,9 +3256,11 @@ static int setup_load_info(struct load_i
  
  static int check_modinfo(struct module *mod, struct load_info *info, int flags)
  {
@@ -125,7 +125,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (flags & MODULE_INIT_IGNORE_VERMAGIC)
                modmagic = NULL;
  
-@@ -3275,6 +3277,7 @@ static int check_modinfo(struct module *
+@@ -3279,6 +3281,7 @@ static int check_modinfo(struct module *
                                mod->name);
                add_taint_module(mod, TAINT_OOT_MODULE, LOCKDEP_STILL_OK);
        }
index c4c13b9695cb121131e851836e4b67910a75e20c..68a2d4d88fc1f7998578c2acad4a2f43d2b53167 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/init/Kconfig
 +++ b/init/Kconfig
-@@ -1277,6 +1277,17 @@ config SYSCTL_ARCH_UNALIGN_ALLOW
+@@ -1280,6 +1280,17 @@ config SYSCTL_ARCH_UNALIGN_ALLOW
          the unaligned access emulation.
          see arch/parisc/kernel/unaligned.c for reference
  
index a137fb5a6d503fa03907c4f4ad823d2278837fa5..d9bfda1303b90368f3af24c26969b489724ab63d 100644 (file)
@@ -95,7 +95,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
        if (sock->type == SOCK_PACKET)
                po->prot_hook.func = packet_rcv_spkt;
-@@ -3922,6 +3925,16 @@ packet_setsockopt(struct socket *sock, i
+@@ -3924,6 +3927,16 @@ packet_setsockopt(struct socket *sock, i
                po->xmit = val ? packet_direct_xmit : dev_queue_xmit;
                return 0;
        }
@@ -112,7 +112,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        default:
                return -ENOPROTOOPT;
        }
-@@ -3978,6 +3991,13 @@ static int packet_getsockopt(struct sock
+@@ -3980,6 +3993,13 @@ static int packet_getsockopt(struct sock
        case PACKET_VNET_HDR:
                val = po->has_vnet_hdr;
                break;
index 7523b396bad3b15427a7c3000bb739da5d3d280c..83db92609b215dabcde2d7804aa46efb3a8dc470 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
 
 --- a/init/Kconfig
 +++ b/init/Kconfig
-@@ -1662,6 +1662,15 @@ config EMBEDDED
+@@ -1665,6 +1665,15 @@ config EMBEDDED
          an embedded system so certain expert options are available
          for configuration.
  
index 07fac213ce3e1b58b6b3ba90a48e231649ef97f3..02562b75873ddce1eca846423da466d274290cad 100644 (file)
@@ -35,7 +35,7 @@ Signed-off-by: Han Xu <han.xu@nxp.com>
  struct nxp_fspi {
        void __iomem *iobase;
        void __iomem *ahb_addr;
-@@ -1083,6 +1099,8 @@ static int nxp_fspi_resume(struct device
+@@ -1082,6 +1098,8 @@ static int nxp_fspi_resume(struct device
  
  static const struct of_device_id nxp_fspi_dt_ids[] = {
        { .compatible = "nxp,lx2160a-fspi", .data = (void *)&lx2160a_data, },
index a8db23cebb5c8d9898d8676bf3bccce48d7f9dce..534c014a2b50dfe38a44f69f21f2c8dcec383b13 100644 (file)
@@ -76,7 +76,7 @@ Signed-off-by: Han Xu <han.xu@nxp.com>
        } else {
                if (op->data.nbytes && op->data.dir == SPI_MEM_DATA_OUT)
                        nxp_fspi_fill_txfifo(f, op);
-@@ -999,9 +1025,8 @@ static int nxp_fspi_probe(struct platfor
+@@ -993,9 +1019,8 @@ static int nxp_fspi_probe(struct platfor
  
        /* find the resources - controller memory mapped space */
        res = platform_get_resource_byname(pdev, IORESOURCE_MEM, "fspi_mmap");
@@ -88,7 +88,7 @@ Signed-off-by: Han Xu <han.xu@nxp.com>
                goto err_put_ctrl;
        }
  
-@@ -1080,6 +1105,9 @@ static int nxp_fspi_remove(struct platfo
+@@ -1079,6 +1104,9 @@ static int nxp_fspi_remove(struct platfo
  
        mutex_destroy(&f->lock);