ath79: add low_mem to tiny image
authorNick Hainke <vincent@systemli.org>
Fri, 19 Aug 2022 16:59:36 +0000 (18:59 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Wed, 5 Oct 2022 19:50:01 +0000 (21:50 +0200)
Devices with SMALL_FLASH enabled have "SQUASHFS_BLOCK_SIZE=1024" in
their config. This significantly increases the cache memory required by
squashfs [0]. This commit enables low_mem leading to a much better
performance because the SQUASHFS_BLOCK_SIZE is reduced to 256.

Example Nanostation M5 (XM):
The image size increases by 128 KiB. However, the memory statisitcs look
much better:

Default tiny build:
------
MemTotal:          26020 kB
MemFree:            5648 kB
MemAvailable:       6112 kB
Buffers:               0 kB
Cached:             3044 kB

low_mem enabled:
-----
MemTotal:          26976 kB
MemFree:            6748 kB
MemAvailable:      11504 kB
Buffers:               0 kB
Cached:             7204 kB

[0] - https://github.com/freifunk-gluon/gluon/commit/7e8af99cf504ca1dc389f282a0c94f4a911571be

Signed-off-by: Nick Hainke <vincent@systemli.org>
(cherry picked from commit f54ac98f8cec676761e5144ae06640b8007b4b04)

target/linux/ath79/tiny/target.mk

index 91f135b56eda4534edfbf68414933cb42a75d1e2..28e02f7a674c434abd1da7a08b145c27822766b4 100644 (file)
@@ -1,5 +1,5 @@
 BOARDNAME:=Devices with small flash
-FEATURES += small_flash
+FEATURES += low_mem small_flash
 
 DEFAULT_PACKAGES += wpad-basic-wolfssl