ar71xx: move Compex WPJ531 to generic build target
authorChristian Mehlis <christian@m3hlis.de>
Tue, 28 Mar 2017 19:12:48 +0000 (21:12 +0200)
committerJohn Crispin <john@phrozen.org>
Wed, 29 Mar 2017 07:04:08 +0000 (09:04 +0200)
Signed-off-by: Christian Mehlis <christian@m3hlis.de>
target/linux/ar71xx/image/generic.mk
target/linux/ar71xx/image/legacy-devices.mk
target/linux/ar71xx/image/legacy.mk

index 91d4ef7567524404e18fecbc0e98c0847a22de13..434ae695aa085d2e3e5e9de8ab601e995ad2b2e2 100644 (file)
@@ -790,6 +790,16 @@ define Device/bhr-4grv2
 endef
 TARGET_DEVICES += bhr-4grv2
 
+define Device/wpj531
+  DEVICE_TITLE := Compex WPJ531 (16MB flash)
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport
+  BOARDNAME := WPJ531
+  MTDPARTS := spi0.0:192k(u-boot)ro,16128k(firmware),64k(art)ro
+  IMAGE_SIZE := 16128k
+  CONSOLE := ttyS0,115200
+endef
+TARGET_DEVICES += wpj531
+
 define Device/wpj558
   DEVICE_TITLE := Compex WPJ558 (16MB flash)
   DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport
index 30968e4bf92d56c8a14ef4e23944972834c0ef8e..ddffe5babecca913a28a468cd541b83c11840032 100644 (file)
@@ -182,11 +182,6 @@ define LegacyDevice/DR344
 endef
 LEGACY_DEVICES += DR344
 
-define LegacyDevice/WPJ531_16M
-  DEVICE_TITLE := Compex WPJ531 (16MB flash)
-endef
-LEGACY_DEVICES += WPJ531_16M
-
 define LegacyDevice/WRTNODE2Q
   DEVICE_TITLE := WRTnode2Q board
   DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-storage
index 9c8a14bf986f979022d00f3a712055dfe1e2809b..fe693e835ff5dfc695b018139d7c0b3d671e0fb0 100644 (file)
@@ -272,7 +272,6 @@ wlr8100_mtdlayout=mtdparts=spi0.0:192k(u-boot)ro,64k(u-boot-env)ro,1408k(kernel)
 wpj342_mtdlayout_16M=mtdparts=spi0.0:192k(u-boot)ro,16128k(firmware),64k(art)ro
 wpj344_mtdlayout_16M=mtdparts=spi0.0:192k(u-boot)ro,16128k(firmware),64k(art)ro
 dr344_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,6336k(rootfs),1408k(kernel),64k(nvram),64k(art)ro,7744k@0x50000(firmware)
-wpj531_mtdlayout_16M=mtdparts=spi0.0:192k(u-boot)ro,16128k(firmware),64k(art)ro
 wndap360_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,7744k(firmware),64k(nvram)ro,64k(art)ro
 wnr2200_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,7808k(firmware),64k(art)ro
 wnr2000_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,3712k(firmware),64k(art)ro
@@ -911,7 +910,6 @@ $(eval $(call SingleProfile,AthLzma,64k,WLR8100,wlr8100,WLR8100,ttyS0,115200,$$(
 $(eval $(call SingleProfile,AthLzma,64k,WPJ342_16M,wpj342-16M,WPJ342,ttyS0,115200,$$(wpj342_mtdlayout_16M),KRuImage,65536))
 $(eval $(call SingleProfile,AthLzma,64k,WPJ344_16M,wpj344-16M,WPJ344,ttyS0,115200,$$(wpj344_mtdlayout_16M),KRuImage,65536))
 $(eval $(call SingleProfile,AthLzma,64k,DR344,dr344,DR344,ttyS0,115200,$$(dr344_mtdlayout),RKuImage))
-$(eval $(call SingleProfile,AthLzma,64k,WPJ531_16M,wpj531-16M,WPJ531,ttyS0,115200,$$(wpj531_mtdlayout_16M),KRuImage,65536))
 $(eval $(call SingleProfile,AthLzma,64k,WRTNODE2Q,wrtnode2q,WRTNODE2Q,ttyS0,115200,$$(wrtnode2q_mtdlayout),KRuImage))
 $(eval $(call SingleProfile,AthLzma,64k,YUN_8M,yun-8M,Yun,ttyATH0,250000,$$(yun_mtdlayout_8M),RKuImage))
 $(eval $(call SingleProfile,AthLzma,64k,YUN_16M,yun-16M,Yun,ttyATH0,250000,$$(yun_mtdlayout_16M),RKuImage))