explicitly set CONFIG_SHELL to bash for the kernel headers configure
authorFelix Fietkau <nbd@openwrt.org>
Tue, 10 Oct 2006 17:14:42 +0000 (17:14 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 10 Oct 2006 17:14:42 +0000 (17:14 +0000)
SVN-Revision: 5025

openwrt/toolchain/kernel-headers/Makefile

index a893b8511c4690889a156cb18c19ff754987893a..a242ea23ac7e404524e2a9af9dfb3687e249f7c5 100644 (file)
@@ -48,7 +48,10 @@ endef
 
 define Build/Configure
        -$(CP) ./files/config.$(LINUX_KARCH) $(PKG_BUILD_DIR)/.config
-       $(MAKE) -C $(PKG_BUILD_DIR) ARCH=$(LINUX_KARCH) oldconfig include/linux/version.h
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               ARCH=$(LINUX_KARCH) \
+               CONFIG_SHELL=$(shell which bash) \
+               oldconfig include/linux/version.h
 endef
 
 define Build/Compile