ar71xx: create firmware images for the TL-WR941ND v4 board
authorGabor Juhos <juhosg@openwrt.org>
Fri, 19 Feb 2010 11:52:33 +0000 (11:52 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Fri, 19 Feb 2010 11:52:33 +0000 (11:52 +0000)
SVN-Revision: 19749

target/linux/ar71xx/image/Makefile
target/linux/ar71xx/profiles/tp-link.mk

index f5bafdb90d78821bface0fbba8586adc6a1ba6ef..c7d4fc147f03ddfe11bdc89c076798f044d8eacb 100644 (file)
@@ -488,6 +488,10 @@ define Image/Build/Profile/TLWR941NDV2
        $(call Image/Build/Template/$(fs_squash)/$(1),TPLINK,tl-wr941nd-v2,board=TL-WR941ND,TL-WR941NDv2)
 endef
 
+define Image/Build/Profile/TLWR941NDV4
+       $(call Image/Build/Template/$(fs_4k)/$(1),TPLINK,tl-wr941nd-v4,board=TL-WR741ND,TL-WR941NDv4)
+endef
+
 define Image/Build/Profile/TLWR1043NDV1
        $(call Image/Build/Template/$(fs_squash)/$(1),TPLINK,tl-wr1043nd-v1,board=TL-WR1043ND,TL-WR1043NDv1)
 endef
@@ -530,6 +534,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/TLWR841NDV3,$(1))
        $(call Image/Build/Profile/TLWR841NDV5,$(1))
        $(call Image/Build/Profile/TLWR941NDV2,$(1))
+       $(call Image/Build/Profile/TLWR941NDV4,$(1))
        $(call Image/Build/Profile/TLWR1043NDV1,$(1))
        $(call Image/Build/Profile/UBNT,$(1))
        $(call Image/Build/Profile/WP543,$(1))
index 09fbcc9e7ec790e52b12e71ea974edf4463a5007..ffb3b9e06d528ee836417c3d5dfcd809c10638d1 100644 (file)
@@ -60,6 +60,17 @@ endef
 
 $(eval $(call Profile,TLWR941NDV2))
 
+define Profile/TLWR941NDV4
+       NAME:=TP-LINK TL-WR941ND v4
+       PACKAGES:=kmod-ath9k wpad-mini
+endef
+
+define Profile/TLWR941NDV4/Description
+       Package set optimized for the TP-LINK TL-WR941ND v4.
+endef
+
+$(eval $(call Profile,TLWR941NDV4))
+
 define Profile/TLWR1043NDV1
        NAME:=TP-LINK TL-WR1043ND v1
        PACKAGES:=kmod-ath9k wpad-mini kmod-usb-core kmod-usb2