add support for glibc-2.4 (#5213)
authorFlorian Fainelli <florian@openwrt.org>
Tue, 26 May 2009 14:58:32 +0000 (14:58 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 26 May 2009 14:58:32 +0000 (14:58 +0000)
SVN-Revision: 16089

toolchain/glibc-ports/patches/2.4/100-mips-fork.patch [new file with mode: 0644]
toolchain/glibc/Config.in
toolchain/glibc/Config.version
toolchain/glibc/Makefile

diff --git a/toolchain/glibc-ports/patches/2.4/100-mips-fork.patch b/toolchain/glibc-ports/patches/2.4/100-mips-fork.patch
new file mode 100644 (file)
index 0000000..8d53f41
--- /dev/null
@@ -0,0 +1,7 @@
+diff --exclude=.svn -pNur  glibc-ports-2.4/sysdeps/unix/sysv/linux/mips/nptl/fork.c glibc-ports-2.4/sysdeps/unix/sysv/linux/mips/nptl/fork.c
+---  glibc-ports-2.4/sysdeps/unix/sysv/linux/mips/nptl/fork.c  2009-02-09 15:13:14.996030533 +0100
++++ glibc-ports-2.4/sysdeps/unix/sysv/linux/mips/nptl/fork.c   2009-02-09 15:13:34.402489340 +0100
+@@ -1 +1,2 @@
+-#include "../i386/fork.c"
++#include <sysdeps/unix/sysv/linux/i386/fork.c>
++
index e1bffdab2b0629dda2a71e0d3823c33ea193e3c1..67ee7297555cfd99357ef7b31001d8acd6ff7045 100644 (file)
@@ -8,6 +8,9 @@ choice
        config GLIBC_VERSION_2_3_6
                bool "glibc 2.3.6"
 
+       config GLIBC_VERSION_2_4
+               bool "glibc 2.4"
+
        config GLIBC_VERSION_2_6_1
                bool "glibc 2.6.1"
 
index 1debf0c040d81189cebecead0909329978a39624..93ea3c31684006f9801ab7bb4e0bd51772c7774d 100644 (file)
@@ -2,6 +2,7 @@ config GLIBC_VERSION
        string
        depends on USE_GLIBC
        default "2.3.6"  if GLIBC_VERSION_2_3_6
+       default "2.4"     if GLIBC_VERSION_2_4
        default "2.6.1"  if GLIBC_VERSION_2_6_1
        default "2.7"    if GLIBC_VERSION_2_7
        default "2.7"
@@ -10,6 +11,7 @@ config GLIBC_PORTS
        bool
        depends on USE_GLIBC
        default y  if GLIBC_VERSION_2_3_6 && (arm || armeb || mips || mipsel || mips64 || mips64el)
+       default y  if GLIBC_VERSION_2_4 && (arm || armeb || mips || mipsel || mips64 || mips64el)
        default y  if GLIBC_VERSION_2_6_1 && (arm || armeb || mips || mipsel || mips64 || mips64el || powerpc)
        default y  if GLIBC_VERSION_2_7 && (arm || armeb || mips || mipsel || mips64 || mips64el || powerpc)
        default n
index 229f20649e48c5fb20128b49a43e4ff87c95ade1..5d56d4b98ad3d9de1bb549091933306a6e80bbd2 100644 (file)
@@ -12,6 +12,9 @@ PKG_VERSION:=$(call qstrip,$(CONFIG_GLIBC_VERSION))
 ifeq ($(PKG_VERSION),2.3.6)
   PKG_MD5SUM:=bfdce99f82d6dbcb64b7f11c05d6bc96
 endif
+ifeq ($(PKG_VERSION),2.4)
+  PKG_MD5SUM:=7e9a88dcd41fbc53801dbe5bdacaf245
+endif
 ifeq ($(PKG_VERSION),2.6.1)
   PKG_MD5SUM:=11cf6d3fc86dbe0890b8d00372eb6286
 endif