ar71xx: allow to override kernel size in the CameoHornet profile
authorGabor Juhos <juhosg@openwrt.org>
Sat, 24 Aug 2013 10:11:45 +0000 (10:11 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sat, 24 Aug 2013 10:11:45 +0000 (10:11 +0000)
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 37833

target/linux/ar71xx/image/Makefile

index f5650c9afe265948f6e9c8608a7662045d7f82ad..7ab6b03b8faef2de16ca6fc21c56bc1ae5dcbc4a 100644 (file)
@@ -358,7 +358,7 @@ define Image/Build/CameoHornet
                        [ -n "$$$$r" ] && dashr="-$$$$r" || dashr=; \
                        [ -z "$$$$r" ] && r="DEF"; \
                        mkcameofw -M HORNET -R "$$$$r" -S $(7) -V $(8) -c \
-                               -K 0xe0000 -I $(10) \
+                               -K $(10) -I $(11) \
                                -k "$(call sysupname,$(1),$(2))" \
                                -o $(call imgname,$(1),$(2))-factory$$$$dashr.bin; \
                done; \
@@ -382,7 +382,7 @@ define Image/Build/Cameo7240/initramfs
 endef
 
 define Image/Build/Cameo933x
-       $(call Image/Build/CameoHornet,$(1),$(2),$(3),$(cameo933x_mtdlayout),65536,2686976,$(4),$(5),$(6),3735552)
+       $(call Image/Build/CameoHornet,$(1),$(2),$(3),$(cameo933x_mtdlayout),65536,2686976,$(4),$(5),$(6),0xe0000,3735552)
 endef
 
 define Image/Build/Cameo933x/initramfs