procd: update to latest git
authorJohn Crispin <john@openwrt.org>
Thu, 11 Sep 2014 12:28:00 +0000 (12:28 +0000)
committerJohn Crispin <john@openwrt.org>
Thu, 11 Sep 2014 12:28:00 +0000 (12:28 +0000)
add support for starting services as !root

Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 42471

package/system/procd/Makefile
package/system/procd/files/procd.sh

index 1f4d7d0a588dedf2ca2f900f34b3d2af71fb8322..451b925eff91c1ea246660efd55abd4ed42a710d 100644 (file)
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=procd
-PKG_VERSION:=2014-08-29
+PKG_VERSION:=2014-09-09
 
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://nbd.name/luci2/procd.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=6a6fa0a6067cb3c522f5dc735e808a68f62b30b2
+PKG_SOURCE_VERSION:=4bd633868e3284659668f14aa39ea84aaadc2dec
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 CMAKE_INSTALL:=1
 
index e4e75edb2e13174afa178d12f08bf92576653aac..109daee64c269824426b4d08ada05aacb2b235cc 100644 (file)
@@ -18,6 +18,7 @@
 #     file: configuration files (array)
 #     netdev: bound network device (detects ifindex changes)
 #     limits: resource limits (passed to the process)
+#     user info: array with 1 values $username
 #
 #   No space separation is done for arrays/tables - use one function argument per command line argument
 #
@@ -139,6 +140,9 @@ _procd_set_param() {
                nice)
                        json_add_int "$type" "$1"
                ;;
+               user)
+                       json_add_string "$type" "$1"
+               ;;
        esac
 }