sunxi: add Orange Pi 2 support
authorZoltan HERPAI <wigyori@uid0.hu>
Mon, 23 Oct 2017 20:33:00 +0000 (22:33 +0200)
committerJohn Crispin <john@phrozen.org>
Mon, 6 Nov 2017 15:39:41 +0000 (16:39 +0100)
- H3 @ 1.3 GHz
- 1GiB DDR3
- 10/100Mbps Ethernet
- Realtek RTL8189ETV wifi
- 4 USB 2.0

Difference to the "Orange Pi Plus" is the lack of Gbit ethernet
and lack of onboard flash.

Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
package/boot/uboot-sunxi/Makefile
target/linux/sunxi/image/cortex-a7.mk

index d986f6259c745edd2b0a0f715189ff1601617bae..c5337c93ec347dd5d8badb9a5ea5eb2f4eceb00d 100644 (file)
@@ -150,6 +150,12 @@ define U-Boot/orangepi_plus
   BUILD_DEVICES:=sun8i-h3-orangepi-plus
 endef
 
+define U-Boot/orangepi_2
+  BUILD_SUBTARGET:=cortexa7
+  NAME:=Orange Pi 2 (H3)
+  BUILD_DEVICES:=sun8i-h3-orangepi-2
+endef
+
 define U-Boot/pangolin
   BUILD_SUBTARGET:=cortexa7
   NAME:=Theobroma A31-yQ7 devboard
@@ -185,6 +191,7 @@ UBOOT_TARGETS := \
        nanopi_neo \
        orangepi_r1 \
        orangepi_plus \
+       orangepi_2 \
        pangolin \
        pine64_plus
 
index d0b7aa04b606f5ea3526d1b2bf9e654bffc56e6f..d219a1d097a3d108eb64e555f2782b061886eb0f 100644 (file)
@@ -136,6 +136,15 @@ endef
 
 TARGET_DEVICES += sun8i-h3-orangepi-plus
 
+define Device/sun8i-h3-orangepi-2
+  DEVICE_TITLE:=Xunlong Orange Pi 2
+  DEVICE_PACKAGES:=kmod-rtc-sunxi
+  SUPPORTED_DEVICES:=xunlong,orangepi-2
+  SUNXI_DTS:=sun8i-h3-orangepi-2
+endef
+
+TARGET_DEVICES += sun8i-h3-orangepi-2
+
 
 define Device/sun7i-a20-pcduino3
   DEVICE_TITLE:=LinkSprite pcDuino3