kernel: Support kernel options required by systemd
authorJohn Crispin <john@openwrt.org>
Sat, 21 Mar 2015 21:48:12 +0000 (21:48 +0000)
committerJohn Crispin <john@openwrt.org>
Sat, 21 Mar 2015 21:48:12 +0000 (21:48 +0000)
These kernel options are all likely to be widely useful in this modern age, but
are immediately useful for systemd support.

c.f. http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/sys-apps/systemd/systemd-9999.ebuild?&view=markup#l118

Adapted from a patch by Adam Porter.

Signed-off-by: Jeff Waugh <jdub@bethesignal.org>
SVN-Revision: 44929

config/Config-kernel.in

index 437a6230d787eda92c2a21ce0266d6f380935cf7..a0d9472dcbb9a981497afa39de3e5aa9037936f0 100644 (file)
@@ -135,6 +135,18 @@ config KERNEL_DIRECT_IO
        bool "Compile the kernel with direct IO support"
        default n
 
        bool "Compile the kernel with direct IO support"
        default n
 
+config KERNEL_FHANDLE
+       bool "Compile the kernel with support for fhandle syscalls"
+       default n
+
+config KERNEL_FANOTIFY
+       bool "Compile the kernel with modern file notification support"
+       default n
+
+config KERNEL_BLK_DEV_BSG
+       bool "Compile the kernel with SCSI generic v4 support for any block device"
+       default n
+
 config KERNEL_MAGIC_SYSRQ
        bool "Compile the kernel with SysRq support"
        default y
 config KERNEL_MAGIC_SYSRQ
        bool "Compile the kernel with SysRq support"
        default y
@@ -184,6 +196,22 @@ config USE_SPARSE
        bool "Enable sparse check during kernel build"
        default n
 
        bool "Enable sparse check during kernel build"
        default n
 
+config KERNEL_DEVTMPFS
+       bool "Compile the kernel with device tmpfs enabled"
+       default n
+       help
+         devtmpfs is a simple, kernel-managed /dev filesystem. The kernel creates
+         devices nodes for all registered devices ti simplify boot, but leaves more
+         complex tasks to userspace (e.g. udev).
+
+if KERNEL_DEVTMPFS
+
+       config KERNEL_DEVTMPFS_MOUNT
+               bool "Automatically mount devtmpfs after root filesystem is mounted"
+               default n
+
+endif
+
 #
 # CGROUP support symbols
 #
 #
 # CGROUP support symbols
 #
@@ -501,9 +529,3 @@ config KERNEL_SECCOMP_FILTER
                default n
                help
                  Build kernel with support for seccomp BPF programs.
                default n
                help
                  Build kernel with support for seccomp BPF programs.
-
-config KERNEL_FHANDLE
-       bool "Enable open by fhandle syscalls"
-               default n
-               help
-                 Build kernel with support for open by fhandle syscalls