fix 2.6.30 lzma tuning patch to output file size at end of kernel, otherwise decompre...
authorFlorian Fainelli <florian@openwrt.org>
Sat, 15 May 2010 19:15:10 +0000 (19:15 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 15 May 2010 19:15:10 +0000 (19:15 +0000)
SVN-Revision: 21458

target/linux/rdc/patches-2.6.30/011-tune_lzma_options.patch

index 7c75ff98bcfb1336bc2ee615173d42eca5820156..d137bdfc88645d5fbb8cae88ca299513cc5b0570 100644 (file)
@@ -1,17 +1,17 @@
 Index: linux-2.6.30.10/scripts/Makefile.lib
 ===================================================================
---- linux-2.6.30.10.orig/scripts/Makefile.lib  2010-05-05 10:55:06.000000000 +0200
-+++ linux-2.6.30.10/scripts/Makefile.lib       2010-05-05 10:55:55.000000000 +0200
+--- linux-2.6.30.10.orig/scripts/Makefile.lib  2010-05-15 16:46:57.000000000 +0200
++++ linux-2.6.30.10/scripts/Makefile.lib       2010-05-15 18:53:02.000000000 +0200
 @@ -204,4 +204,4 @@
  # ---------------------------------------------------------------------------
  
  quiet_cmd_lzma = LZMA    $@
 -cmd_lzma = lzma e $< $@ -lc1 -lp2 -pb2 -eos
-+cmd_lzma = lzma e $< $@ -lc8 -eos
++cmd_lzma = (lzma e $< -lc8 -eos -so && $(size_append) $<) > $@ || (rm -f $@ ; false)
 Index: linux-2.6.30.10/arch/x86/include/asm/boot.h
 ===================================================================
---- linux-2.6.30.10.orig/arch/x86/include/asm/boot.h   2009-12-04 07:00:07.000000000 +0100
-+++ linux-2.6.30.10/arch/x86/include/asm/boot.h        2010-05-05 10:55:23.000000000 +0200
+--- linux-2.6.30.10.orig/arch/x86/include/asm/boot.h   2010-05-15 16:45:57.000000000 +0200
++++ linux-2.6.30.10/arch/x86/include/asm/boot.h        2010-05-15 16:46:58.000000000 +0200
 @@ -13,7 +13,7 @@
                                + (CONFIG_PHYSICAL_ALIGN - 1)) \
                                & ~(CONFIG_PHYSICAL_ALIGN - 1))