generate package for the new IXP4xx crpyto driver
authorImre Kaloz <kaloz@openwrt.org>
Sat, 12 Jul 2008 02:00:55 +0000 (02:00 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Sat, 12 Jul 2008 02:00:55 +0000 (02:00 +0000)
SVN-Revision: 11777

package/kernel/modules/other.mk

index a096552bdd14099fdf44aa87b1eda0ded9182f14..a27149bb05d19a266296ce8e1aeee99ada23b448 100644 (file)
@@ -652,3 +652,21 @@ endef
 
 $(eval $(call KernelPackage,spi-dev))
 
 
 $(eval $(call KernelPackage,spi-dev))
 
+define KernelPackage/crypto-dev-ixp4xx
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=IXP4xx crypto driver
+  DEPENDS:=\
+       @TARGET_ixp4xx +kmod-crypto-core +kmod-crypto-des +kmod-crypto-aead \
+       +kmod-crypto-authenc
+  KCONFIG:=\
+       CONFIG_CRYPTO_HW=y \
+       CONFIG_CRYPTO_DEV_IXP4XX
+  FILES:=$(LINUX_DIR)/drivers/crypto/ixp4xx_crypto.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,90,ixp4xx_crypto)
+endef
+
+define KernelPackage/crypto-dev-ixp4xx/description
+ Kernel support for the IXP4xx HW crypto engine.
+endef
+
+$(eval $(call KernelPackage,crypto-dev-ixp4xx))