kernel: btrfs: enable ACL
authorJosef Schlehofer <josef.schlehofer@nic.cz>
Thu, 16 May 2019 15:23:12 +0000 (17:23 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 5 Dec 2021 17:49:14 +0000 (18:49 +0100)
By default CONFIG_BTRFS_FS_POSIX_ACL is disabled, it should be enabled
only when you enable CONFIG_FS_POSIX_ACL.

Right now, when you enable CONFIG_FS_POSIX_ACL it will enable
CONFIG_BTRFS_FS_POSIX_ACL, but it will be disabled once you install
kmod-btrfs. This should prevent it.

Btrfs has enabled by default ACL for mount option.

More details:
https://cateee.net/lkddb/web-lkddb/BTRFS_FS_POSIX_ACL.html
https://btrfs.wiki.kernel.org/index.php/Manpage/btrfs(5)

Signed-off-by: Josef Schlehofer <josef.schlehofer@nic.cz>
package/kernel/linux/modules/fs.mk

index 7de1a0673cec754704be4d49af1908d12f977820..f9e1b132c7ebbd397c1c1ca26f2549b264183de9 100644 (file)
@@ -70,7 +70,6 @@ define KernelPackage/fs-btrfs
   DEPENDS:=+kmod-lib-crc32c +kmod-lib-lzo +kmod-lib-zlib-inflate +kmod-lib-zlib-deflate +kmod-lib-raid6 +kmod-lib-xor +kmod-lib-zstd
   KCONFIG:=\
        CONFIG_BTRFS_FS \
-       CONFIG_BTRFS_FS_POSIX_ACL=n \
        CONFIG_BTRFS_FS_CHECK_INTEGRITY=n
   FILES:=\
        $(LINUX_DIR)/fs/btrfs/btrfs.ko