target/sdk: fix parallel build calls
authorFelix Fietkau <nbd@openwrt.org>
Thu, 13 Mar 2014 12:12:50 +0000 (12:12 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 13 Mar 2014 12:12:50 +0000 (12:12 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 39912

target/sdk/files/Makefile

index a3fefaa89d2f51b87978cc490e0849f6c3d92b8a..0c27f1a47308bc5d41d37560bc23e7833810bcb5 100644 (file)
@@ -19,6 +19,11 @@ include $(TOPDIR)/include/host.mk
 ifneq ($(OPENWRT_BUILD),1)
   override OPENWRT_BUILD=1
   export OPENWRT_BUILD
 ifneq ($(OPENWRT_BUILD),1)
   override OPENWRT_BUILD=1
   export OPENWRT_BUILD
+
+  empty:=
+  space:= $(empty) $(empty)
+  _SINGLE=export MAKEFLAGS=$(space);
+
   include $(TOPDIR)/include/debug.mk
   include $(TOPDIR)/include/depends.mk
   include $(TOPDIR)/include/toplevel.mk
   include $(TOPDIR)/include/debug.mk
   include $(TOPDIR)/include/depends.mk
   include $(TOPDIR)/include/toplevel.mk