update to latest 2.6.27.26 stable kernel
authorFlorian Fainelli <florian@openwrt.org>
Fri, 3 Jul 2009 09:31:52 +0000 (09:31 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Fri, 3 Jul 2009 09:31:52 +0000 (09:31 +0000)
SVN-Revision: 16659

12 files changed:
include/kernel-version.mk
target/linux/ar7/Makefile
target/linux/brcm63xx/Makefile
target/linux/brcm63xx/patches-2.6.27/002-add_support_for_broadcom_63xx_cpus.patch
target/linux/generic-2.6/patches-2.6.27/023-mips_delay_gcc4.4.0.patch
target/linux/generic-2.6/patches-2.6.27/024-mips_disable_fpu.patch
target/linux/generic-2.6/patches-2.6.27/202-mips-freestanding.patch
target/linux/generic-2.6/patches-2.6.27/208-rtl8110sb_fix.patch
target/linux/generic-2.6/patches-2.6.27/801-usb_serial_endpoint_size.patch
target/linux/generic-2.6/patches-2.6.27/971-ocf_20080917.patch
target/linux/generic-2.6/patches-2.6.27/980-vm_exports.patch
target/linux/olpc/Makefile

index c2ed6de0dc26a2db8269d5fecc339aec5ef9ae2b..f502ab34653584bbfda9afa91c0d8583d3ad32de 100644 (file)
@@ -19,8 +19,8 @@ endif
 ifeq ($(LINUX_VERSION),2.6.25.20)
   LINUX_KERNEL_MD5SUM:=0da698edccf03e2235abc2830a495114
 endif
-ifeq ($(LINUX_VERSION),2.6.27.25)
-  LINUX_KERNEL_MD5SUM:=5d6dcff157f30d742c9ee28ad4589779
+ifeq ($(LINUX_VERSION),2.6.27.26)
+  LINUX_KERNEL_MD5SUM:=6c246d71fa4698fb0dee0ed092f0282b
 endif
 ifeq ($(LINUX_VERSION),2.6.28.10)
   LINUX_KERNEL_MD5SUM:=c4efb2c494d749cb5de274f8ae41c3fa
index 80b7726244e7891f36bbc6250ad618f5cf0a6e9f..b6055d1f7544150686fdd77aafadd807a9267803 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=ar7
 BOARDNAME:=TI AR7
 FEATURES:=squashfs jffs2 atm
 
-LINUX_VERSION:=2.6.27.25
+LINUX_VERSION:=2.6.27.26
 
 include $(INCLUDE_DIR)/target.mk
 
index c168ed6ba7e13ade33e733e5c7d57b60fd07ebcf..200040b0bcc51376bafa029a1314ce653531fe0b 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
 FEATURES:=squashfs jffs2 usb atm pci pcmcia
-LINUX_VERSION:=2.6.27.25
+LINUX_VERSION:=2.6.27.26
 
 include $(INCLUDE_DIR)/target.mk
 
index 90603dcf88d3aeb9d886ac6c884a5df522636134..af494f495932df0b38a5abc851582d2cfccbea04 100644 (file)
@@ -88,7 +88,7 @@ Signed-off-by: Maxime Bizon <mbizon@freebox.fr>
  source "arch/mips/pmc-sierra/Kconfig"
 --- a/arch/mips/Makefile
 +++ b/arch/mips/Makefile
-@@ -533,6 +533,13 @@ cflags-$(CONFIG_BCM47XX)  += -Iinclude/as
+@@ -540,6 +540,13 @@ cflags-$(CONFIG_BCM47XX)  += -Iinclude/as
  load-$(CONFIG_BCM47XX)                := 0xffffffff80001000
  
  #
index f001b81e10732d11ac6252535abc9af2ffcfc3ad..4f7f327889513b9c5a81f3dbf0280bee9a9f5624 100644 (file)
@@ -21,11 +21,9 @@ Signed-off-by: Wu Zhangjin <wuzhangjin@gmail.com>
  arch/mips/include/asm/delay.h    |   58 +++++++++++++++++++++++++------------
  3 files changed, 57 insertions(+), 20 deletions(-)
 
-diff --git a/arch/mips/Makefile b/arch/mips/Makefile
-index a25c2e5..1ee5504 100644
 --- a/arch/mips/Makefile
 +++ b/arch/mips/Makefile
-@@ -120,7 +120,14 @@ cflags-$(CONFIG_CPU_R4300)        += -march=r4300 -Wa,--trap
+@@ -119,7 +119,14 @@ cflags-$(CONFIG_CPU_R4300)        += -march=r43
  cflags-$(CONFIG_CPU_VR41XX)   += -march=r4100 -Wa,--trap
  cflags-$(CONFIG_CPU_R4X00)    += -march=r4600 -Wa,--trap
  cflags-$(CONFIG_CPU_TX49XX)   += -march=r4600 -Wa,--trap
@@ -41,8 +39,6 @@ index a25c2e5..1ee5504 100644
  cflags-$(CONFIG_CPU_MIPS32_R1)        += $(call cc-option,-march=mips32,-mips32 -U_MIPS_ISA -D_MIPS_ISA=_MIPS_ISA_MIPS32) \
                        -Wa,-mips32 -Wa,--trap
  cflags-$(CONFIG_CPU_MIPS32_R2)        += $(call cc-option,-march=mips32r2,-mips32r2 -U_MIPS_ISA -D_MIPS_ISA=_MIPS_ISA_MIPS32) \
-diff --git a/include/asm-mips/compiler.h b/include/asm-mips/compiler.h
-index 71f5c5c..95256a8 100644
 --- a/include/asm-mips/compiler.h
 +++ b/include/asm-mips/compiler.h
 @@ -1,5 +1,6 @@
@@ -66,8 +62,6 @@ index 71f5c5c..95256a8 100644
 +#endif
 +
  #endif /* _ASM_COMPILER_H */
-diff --git a/include/asm-mips/delay.h b/include/asm-mips/delay.h
-index b0bccd2..00d7969 100644
 --- a/include/asm-mips/delay.h
 +++ b/include/asm-mips/delay.h
 @@ -7,6 +7,7 @@
@@ -78,7 +72,7 @@ index b0bccd2..00d7969 100644
   */
  #ifndef _ASM_DELAY_H
  #define _ASM_DELAY_H
-@@ -48,6 +49,43 @@ static inline void __delay(unsigned long loops)
+@@ -48,6 +49,43 @@ static inline void __delay(unsigned long
                : "0" (loops), "r" (1));
  }
  
@@ -122,7 +116,7 @@ index b0bccd2..00d7969 100644
  
  /*
   * Division by multiplication: you don't have to worry about
-@@ -62,8 +100,6 @@ static inline void __delay(unsigned long loops)
+@@ -62,8 +100,6 @@ static inline void __delay(unsigned long
  
  static inline void __udelay(unsigned long usecs, unsigned long lpj)
  {
@@ -131,7 +125,7 @@ index b0bccd2..00d7969 100644
        /*
         * The rates of 128 is rounded wrongly by the catchall case
         * for 64-bit.  Excessive precission?  Probably ...
-@@ -77,23 +113,7 @@ static inline void __udelay(unsigned long usecs, unsigned long lpj)
+@@ -77,23 +113,7 @@ static inline void __udelay(unsigned lon
                                   0x80000000ULL) >> 32);
  #endif
  
@@ -156,8 +150,3 @@ index b0bccd2..00d7969 100644
  }
  
  #define __udelay_val cpu_data[raw_smp_processor_id()].udelay_val
--- 
-1.6.0.4
-
-
-
index e71bf48f2103b03b11699765caa8d34948aa7248..60e844b279e104aecee12a19df84b9d9c17a5676 100644 (file)
@@ -6,11 +6,9 @@ precious blocks on an embedded system.
 
 Signed-off-by: Florian Fainelli <florian@openwrt.org>
 --
-diff --git a/arch/mips/Kconfig b/arch/mips/Kconfig
-index 65d3b19..a467ee5 100644
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -811,6 +811,17 @@ config I8259
+@@ -756,6 +756,17 @@ config I8259
  config MIPS_BONITO64
        bool
  
@@ -28,8 +26,6 @@ index 65d3b19..a467ee5 100644
  config MIPS_MSC
        bool
  
-diff --git a/arch/mips/math-emu/Makefile b/arch/mips/math-emu/Makefile
-index d547efd..7fdef24 100644
 --- a/arch/mips/math-emu/Makefile
 +++ b/arch/mips/math-emu/Makefile
 @@ -2,12 +2,14 @@
@@ -49,11 +45,9 @@ index d547efd..7fdef24 100644
 +         dp_sqrt.o sp_sqrt.o
  
  EXTRA_CFLAGS += -Werror
-diff --git a/arch/mips/math-emu/cp1emu.c b/arch/mips/math-emu/cp1emu.c
-index 890f779..9f4c767 100644
 --- a/arch/mips/math-emu/cp1emu.c
 +++ b/arch/mips/math-emu/cp1emu.c
-@@ -56,6 +56,12 @@
+@@ -57,6 +57,12 @@
  #endif
  #define __mips 4
  
@@ -66,7 +60,7 @@ index 890f779..9f4c767 100644
  /* Function which emulates a floating point instruction. */
  
  static int fpu_emu(struct pt_regs *, struct mips_fpu_struct *,
-@@ -66,10 +72,6 @@ static int fpux_emu(struct pt_regs *,
+@@ -67,10 +73,6 @@ static int fpux_emu(struct pt_regs *,
        struct mips_fpu_struct *, mips_instruction);
  #endif
  
@@ -77,7 +71,7 @@ index 890f779..9f4c767 100644
  /* Control registers */
  
  #define FPCREG_RID    0       /* $0  = revision id */
-@@ -1273,6 +1275,13 @@ int fpu_emulator_cop1Handler(struct pt_regs *xcp, struct mips_fpu_struct *ctx,
+@@ -1277,6 +1279,13 @@ int fpu_emulator_cop1Handler(struct pt_r
  
        return sig;
  }
@@ -91,11 +85,9 @@ index 890f779..9f4c767 100644
  
  #ifdef CONFIG_DEBUG_FS
  extern struct dentry *mips_debugfs_dir;
-diff --git a/arch/mips/math-emu/dsemul.c b/arch/mips/math-emu/dsemul.c
-index df7b9d9..9b42bfd 100644
 --- a/arch/mips/math-emu/dsemul.c
 +++ b/arch/mips/math-emu/dsemul.c
-@@ -109,6 +109,7 @@ int mips_dsemul(struct pt_regs *regs, mips_instruction ir, unsigned long cpc)
+@@ -110,6 +110,7 @@ int mips_dsemul(struct pt_regs *regs, mi
        return SIGILL;          /* force out of emulation loop */
  }
  
@@ -103,7 +95,7 @@ index df7b9d9..9b42bfd 100644
  int do_dsemulret(struct pt_regs *xcp)
  {
        struct emuframe __user *fr;
-@@ -165,3 +166,9 @@ int do_dsemulret(struct pt_regs *xcp)
+@@ -166,3 +167,9 @@ int do_dsemulret(struct pt_regs *xcp)
  
        return 1;
  }
@@ -113,8 +105,6 @@ index df7b9d9..9b42bfd 100644
 +      return 0;
 +}
 +#endif /* CONFIG_MIPS_FPU_EMU */
-diff --git a/arch/mips/math-emu/kernel_linkage.c b/arch/mips/math-emu/kernel_linkage.c
-index 52e6c58..211a399 100644
 --- a/arch/mips/math-emu/kernel_linkage.c
 +++ b/arch/mips/math-emu/kernel_linkage.c
 @@ -29,6 +29,7 @@
@@ -125,7 +115,7 @@ index 52e6c58..211a399 100644
  void fpu_emulator_init_fpu(void)
  {
        static int first = 1;
-@@ -112,4 +113,34 @@ int fpu_emulator_restore_context32(struct sigcontext32 __user *sc)
+@@ -112,4 +113,34 @@ int fpu_emulator_restore_context32(struc
  
        return err;
  }
index 156510b02d457947894df53eff823e98ac9843ca..a26d3f2e0e9f310b00ec645399fa34af7a734a98 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/Makefile
 +++ b/arch/mips/Makefile
-@@ -577,6 +577,9 @@ core-$(CONFIG_TOSHIBA_RBTX4927)    += arch/
+@@ -584,6 +584,9 @@ core-$(CONFIG_TOSHIBA_RBTX4927)    += arch/
  #
  core-$(CONFIG_TOSHIBA_RBTX4938) += arch/mips/txx9/rbtx4938/
  
index 4d8dfeb55fe047e4df4ca0c52809df5f523d35f8..e89f81754a68e4e5fcb6752e28edced805197d82 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/r8169.c
 +++ b/drivers/net/r8169.c
-@@ -1527,7 +1527,7 @@ static const struct rtl_cfg_info {
+@@ -1526,7 +1526,7 @@ static const struct rtl_cfg_info {
                .hw_start       = rtl_hw_start_8169,
                .region         = 1,
                .align          = 0,
@@ -9,7 +9,7 @@
                                  RxFIFOOver | TxErr | TxOK | RxOK | RxErr,
                .napi_event     = RxFIFOOver | TxErr | TxOK | RxOK | RxOverflow,
                .features       = RTL_FEATURE_GMII
-@@ -1536,7 +1536,7 @@ static const struct rtl_cfg_info {
+@@ -1535,7 +1535,7 @@ static const struct rtl_cfg_info {
                .hw_start       = rtl_hw_start_8168,
                .region         = 2,
                .align          = 8,
@@ -18,7 +18,7 @@
                                  TxErr | TxOK | RxOK | RxErr,
                .napi_event     = TxErr | TxOK | RxOK | RxOverflow,
                .features       = RTL_FEATURE_GMII | RTL_FEATURE_MSI
-@@ -1545,7 +1545,7 @@ static const struct rtl_cfg_info {
+@@ -1544,7 +1544,7 @@ static const struct rtl_cfg_info {
                .hw_start       = rtl_hw_start_8101,
                .region         = 2,
                .align          = 8,
@@ -27,7 +27,7 @@
                                  RxFIFOOver | TxErr | TxOK | RxOK | RxErr,
                .napi_event     = RxFIFOOver | TxErr | TxOK | RxOK | RxOverflow,
                .features       = RTL_FEATURE_MSI
-@@ -2879,10 +2879,12 @@ static irqreturn_t rtl8169_interrupt(int
+@@ -2878,10 +2878,12 @@ static irqreturn_t rtl8169_interrupt(int
                goto out;
        }
  
index e96e01cd556da2ac7338661ef3b895b3aa36d3ac..78681d2b4a53ebf74edcca571bddb9ce83fc6a63 100644 (file)
@@ -8,7 +8,7 @@
  static int debug;
  /* initially all NULL */
  static struct usb_serial *serial_table[SERIAL_TTY_MINORS];
-@@ -835,7 +836,7 @@ int usb_serial_probe(struct usb_interfac
+@@ -856,7 +857,7 @@ int usb_serial_probe(struct usb_interfac
                        dev_err(&interface->dev, "No free urbs available\n");
                        goto probe_error;
                }
@@ -17,7 +17,7 @@
                port->bulk_in_size = buffer_size;
                port->bulk_in_endpointAddress = endpoint->bEndpointAddress;
                port->bulk_in_buffer = kmalloc(buffer_size, GFP_KERNEL);
-@@ -1255,3 +1256,5 @@ MODULE_LICENSE("GPL");
+@@ -1292,3 +1293,5 @@ MODULE_LICENSE("GPL");
  
  module_param(debug, bool, S_IRUGO | S_IWUSR);
  MODULE_PARM_DESC(debug, "Debug enabled or not");
index ebed01db811daa40392b12b08e9bb7af1a65e26e..3a84e6e4d0022cb152a985973bd4850cc94b974c 100644 (file)
@@ -88,7 +88,7 @@
  /*********************************************************************
 --- a/fs/fcntl.c
 +++ b/fs/fcntl.c
-@@ -140,6 +140,7 @@ SYSCALL_DEFINE1(dup, unsigned int, filde
+@@ -142,6 +142,7 @@ SYSCALL_DEFINE1(dup, unsigned int, filde
        }
        return ret;
  }
index 35126ee8ff9746f0488dd03b43d6a0a4d18ec058..58c6289e481286e9df6071562b31e31e557fc1d8 100644 (file)
@@ -86,7 +86,7 @@
  
  /**
   * zap_vma_ptes - remove ptes mapping the vma
-@@ -2241,6 +2242,7 @@ int vmtruncate_range(struct inode *inode
+@@ -2287,6 +2288,7 @@ int vmtruncate_range(struct inode *inode
  
        return 0;
  }
index c7d542e897741186064537107be496745e9b21c0..c1e2da146dde3a9ca290b6d73073d6f04bf9d7f5 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=olpc
 BOARDNAME:=OLPC XO-1
 FEATURES:=squashfs ext2
 
-LINUX_VERSION:=2.6.27.25
+LINUX_VERSION:=2.6.27.26
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci