curl: allow enabling https protocol
authorJohn Crispin <john@openwrt.org>
Sat, 17 Jan 2015 13:57:56 +0000 (13:57 +0000)
committerJohn Crispin <john@openwrt.org>
Sat, 17 Jan 2015 13:57:56 +0000 (13:57 +0000)
Provide optional --enable-https flag for curl.

Signed-off-by: Lars Kruse <devel@sumpfralle.de>
SVN-Revision: 43997

package/network/utils/curl/Config.in
package/network/utils/curl/Makefile

index 086f5c24456dd04efa2215b3785f7fadb22aa3bb..026dcd68042f66d89d5f8edb752971cb283e4b99 100644 (file)
@@ -53,6 +53,10 @@ config LIBCURL_HTTP
        bool "Enable HTTP support"
        default y
 
+config LIBCURL_HTTPS
+       bool "Enable HTTPS support"
+       default n
+
 config LIBCURL_IMAP
        bool "Enable IMAP support"
        default n
index f78fa9e9a247e32ff403b2db84244a217ce58e6a..1a374951c1e50a798a2e8b5d0109312497d0803d 100644 (file)
@@ -37,6 +37,7 @@ PKG_CONFIG_DEPENDS := \
   LIBCURL_GNUTLS \
   LIBCURL_GOPHER \
   LIBCURL_HTTP \
+  LIBCURL_HTTPS \
   LIBCURL_IMAP \
   LIBCURL_LDAP \
   LIBCURL_LDAPS \
@@ -113,6 +114,7 @@ CONFIGURE_ARGS += \
        $(if $(CONFIG_LIBCURL_GOPHER),--enable,--disable)-gopher \
        $(if $(CONFIG_LIBCURL_GNUTLS),--with-gnutls="$(STAGING_DIR)/usr",--without-gnutls) \
        $(if $(CONFIG_LIBCURL_HTTP),--enable,--disable)-http \
+       $(if $(CONFIG_LIBCURL_HTTPS),--enable,--disable)-https \
        $(if $(CONFIG_LIBCURL_IMAP),--enable,--disable)-imap \
        $(if $(CONFIG_LIBCURL_LDAP),--enable,--disable)-ldap \
        $(if $(CONFIG_LIBCURL_LDAPS),--enable,--disable)-ldaps \