ath79: Add support for OpenMesh OM2P v2
authorSven Eckelmann <sven@narfation.org>
Mon, 23 Nov 2020 12:41:34 +0000 (13:41 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Wed, 30 Dec 2020 22:32:07 +0000 (23:32 +0100)
Device specifications:
======================

* Qualcomm/Atheros AR9330 rev 1
* 400/400/200 MHz (CPU/DDR/AHB)
* 64 MB of RAM
* 16 MB of SPI NOR flash
  - 2x 7 MB available; but one of the 7 MB regions is the recovery image
* 2x 10/100 Mbps Ethernet
* 1T1R 2.4 GHz Wi-Fi
* 6x GPIO-LEDs (3x wifi, 2x ethernet, 1x power)
* 1x GPIO-button (reset)
* external h/w watchdog (enabled by default)
* TTL pins are on board (arrow points to VCC, then follows: GND, TX, RX)
* 2x fast ethernet
  - eth0
    + builtin switch port 1
    + used as LAN interface
  - eth1
    + 18-24V passive POE (mode B)
    + used as WAN interface
* 12-24V 1A DC
* external antenna

Flashing instructions:
======================

Various methods can be used to install the actual image on the flash.
Two easy ones are:

ap51-flash
----------

The tool ap51-flash (https://github.com/ap51-flash/ap51-flash) should be
used to transfer the image to the u-boot when the device boots up.

initramfs from TFTP
-------------------

The serial console must be used to access the u-boot shell during bootup.
It can then be used to first boot up the initramfs image from a TFTP server
(here with the IP 192.168.1.21):

   setenv serverip 192.168.1.21
   setenv ipaddr 192.168.1.1
   tftpboot 0c00000 <filename-of-initramfs-kernel>.bin && bootm $fileaddr

The actual sysupgrade image can then be transferred (on the LAN port) to
the device via

  scp <filename-of-squashfs-sysupgrade>.bin root@192.168.1.1:/tmp/

On the device, the sysupgrade must then be started using

  sysupgrade -n /tmp/<filename-of-squashfs-sysupgrade>.bin

Signed-off-by: Sven Eckelmann <sven@narfation.org>
package/boot/uboot-envtools/Makefile
package/boot/uboot-envtools/files/ath79
target/linux/ath79/dts/ar9330_openmesh_om2p-v2.dts [new file with mode: 0644]
target/linux/ath79/generic/base-files/etc/board.d/01_leds
target/linux/ath79/generic/base-files/lib/upgrade/platform.sh
target/linux/ath79/image/generic.mk

index 7dcc3ef4284449ebc0b7968f205d14b11dd1e47a..92caed4be721aa92b2beadc63b286651cc9fa516 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=uboot-envtools
 PKG_DISTNAME:=u-boot
 PKG_VERSION:=2020.04
-PKG_RELEASE:=15
+PKG_RELEASE:=16
 
 PKG_SOURCE:=$(PKG_DISTNAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:= \
index 70331b694ade01a27398afa2fd19813d7db0d589..55c1ce8f638f35f62f3dffde4ceaf8c5da02b518 100644 (file)
@@ -85,6 +85,7 @@ netgear,wndr4300tn|\
 netgear,wndr4300sw)
        ubootenv_add_uci_config "/dev/mtd1" "0x0" "0x40000" "0x20000"
        ;;
+openmesh,om2p-v2|\
 openmesh,om2p-v4|\
 openmesh,om2p-hs-v1|\
 openmesh,om2p-hs-v2|\
diff --git a/target/linux/ath79/dts/ar9330_openmesh_om2p-v2.dts b/target/linux/ath79/dts/ar9330_openmesh_om2p-v2.dts
new file mode 100644 (file)
index 0000000..659a1c7
--- /dev/null
@@ -0,0 +1,8 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "ar9330_openmesh_om2p.dtsi"
+
+/ {
+       compatible = "openmesh,om2p-v2", "qca,ar9330";
+       model = "OpenMesh OM2P v2";
+};
index b651432dca8be846f010c9ca1510974996211d8d..8f0e2f87a72573ed3b2261a66c7cbdb2dbcf0594 100755 (executable)
@@ -145,6 +145,7 @@ comfast,cf-e560ac)
        ucidef_set_led_switch "lan4" "LAN4" "blue:lan4" "switch0" "0x10"
        ;;
 comfast,cf-ew72|\
+openmesh,om2p-v2|\
 openmesh,om2p-hs-v1|\
 openmesh,om2p-hs-v2|\
 openmesh,om2p-hs-v3|\
index ea3d9d6d845ad103f66aad54d60f550bb087f8dc..2c907ac1010a8c1dec12478dfa096792c0242388 100644 (file)
@@ -50,6 +50,7 @@ platform_do_upgrade() {
        jjplus,ja76pf2)
                redboot_fis_do_upgrade "$1" linux
                ;;
+       openmesh,om2p-v2|\
        openmesh,om2p-v4|\
        openmesh,om2p-hs-v1|\
        openmesh,om2p-hs-v2|\
index 6f21db78d2c6c650e85a7d2a08653fc7f23b7871..acb456ba44171bc62f3b7e05ef5d96a94ec490e2 100644 (file)
@@ -1568,6 +1568,15 @@ define Device/openmesh_om2p-common
        openmesh-image ce_type=OM2P | append-metadata
 endef
 
+define Device/openmesh_om2p-v2
+  $(Device/openmesh_om2p-common)
+  SOC := ar9330
+  DEVICE_MODEL := OM2P
+  DEVICE_VARIANT := v2
+  SUPPORTED_DEVICES += om2pv2
+endef
+TARGET_DEVICES += openmesh_om2p-v2
+
 define Device/openmesh_om2p-v4
   $(Device/openmesh_om2p-common)
   SOC := qca9533