mediatek: build ubnt-ledbar as a module
[openwrt/staging/981213.git] / target / linux / mediatek / modules.mk
index 467934256c64c4bc6a50b618530d80f328a59a87..0eb2866cf060441dc85c88fda3102e6b003e1fca 100644 (file)
@@ -38,3 +38,19 @@ define KernelPackage/sdhci-mtk
 endef
 
 $(eval $(call KernelPackage,sdhci-mtk))
+
+define KernelPackage/leds-ubnt-ledbar
+  SUBMENU:=LED modules
+  TITLE:=Ubiquiti UniFi 6 LR LED support
+  KCONFIG:=CONFIG_LEDS_UBNT_LEDBAR
+  FILES:= \
+       $(LINUX_DIR)/drivers/leds/leds-ubnt-ledbar.ko
+  AUTOLOAD:=$(call AutoProbe,leds-ubnt-ledbar,1)
+  DEPENDS:=@TARGET_mediatek_mt7622 +kmod-i2c-core
+endef
+
+define KernelPackage/leds-ubnt-ledbar/description
+  LED support for Ubiquiti UniFi 6 LR
+endef
+
+$(eval $(call KernelPackage,leds-ubnt-ledbar))