ramips: allow custom trx magic for Arcadyan
authorMikhail Zhilkin <csharper2005@gmail.com>
Thu, 28 Apr 2022 18:24:07 +0000 (18:24 +0000)
committerChuanhong Guo <gch981213@gmail.com>
Sun, 12 Jun 2022 14:25:05 +0000 (22:25 +0800)
This commit:
1. Renames beeline-trx recipe in mt7621.mk to arcadyan-trx. The recipe
   is necessary for:
   - MTS WG430223 (Arcadyan WG430223)
   - Beeline Smartbox Flash (Arcadyan WG443223)
2. Allows specify custom trx magic which is different for the routers
   mentined above.

Signed-off-by: Mikhail Zhilkin <csharper2005@gmail.com>
target/linux/ramips/image/mt7621.mk

index a485a5043a0a6b5cb1d4dfc72d7e80aa8ae499f7..6ea827b41c7cd4dd6a1ef650db3c8e8931f136cf 100644 (file)
@@ -13,9 +13,10 @@ ifdef CONFIG_LINUX_5_10
   DTS_CPPFLAGS += -DDTS_LEGACY
 endif
 
-define Build/beeline-trx
+define Build/arcadyan-trx
        echo -ne "hsqs" > $@.hsqs
-       $(STAGING_DIR_HOST)/bin/otrx create $@.trx -M 0x746f435d -f $@ \
+       $(eval trx_magic=$(word 1,$(1)))
+       $(STAGING_DIR_HOST)/bin/otrx create $@.trx -M $(trx_magic) -f $@ \
                -a 0x20000 -b 0x420000 -f $@.hsqs -a 1000
        mv $@.trx $@
        dd if=/dev/zero bs=1024 count=1 >> $@.tail
@@ -242,7 +243,7 @@ define Device/beeline_smartbox-flash
   BLOCKSIZE := 128k
   PAGESIZE := 2048
   KERNEL := kernel-bin | append-dtb | lzma | loader-kernel | \
-       uImage none | beeline-trx | pad-to $$(KERNEL_SIZE)
+       uImage none | arcadyan-trx 0x746f435d | pad-to $$(KERNEL_SIZE)
   KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | loader-kernel | \
        uImage none
   IMAGES += factory.trx