ath79: do not build TP-Link tiny images by default
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Mon, 22 Jun 2020 11:50:04 +0000 (13:50 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sun, 28 Jun 2020 12:37:22 +0000 (14:37 +0200)
For quite some time, the tiny (4M flash) TP-Link sysupgrade and
factory images cannot be built anymore by the buildbots, just
the initramfs-kernel.bin files are still there.

Disable these images for the buildbots and don't waste build
resources.

Note that these devices still build fine with default settings,
just not with the additional packages and config symbols for
the buildbots.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ath79/image/common-tp-link.mk

index 6efff6322e9bc05fdac0a945ff1f3a113d368689..01733b01c54d28346b71e3a2d53476b3be257e7c 100644 (file)
@@ -71,12 +71,14 @@ define Device/tplink-4m
   $(Device/tplink-nolzma)
   TPLINK_FLASHLAYOUT := 4M
   IMAGE_SIZE := 3904k
+  DEFAULT := n
 endef
 
 define Device/tplink-4mlzma
   $(Device/tplink)
   TPLINK_FLASHLAYOUT := 4Mlzma
   IMAGE_SIZE := 3904k
+  DEFAULT := n
 endef
 
 define Device/tplink-8m