ath79: add support for TP-Link Archer C7 v1
authorChristian Lamparter <chunkeey@gmail.com>
Fri, 17 Aug 2018 16:36:32 +0000 (18:36 +0200)
committerMathias Kresin <dev@kresin.me>
Sun, 19 Aug 2018 16:48:43 +0000 (18:48 +0200)
TP-Link Archer C7 v1 is a dual band router
based on Qualcomm/Atheros QCA9558 + QCA9880.

Specification:

 - 720 MHz CPU
 - 128 MB of RAM (Various chips)
 - 8 MB of FLASH (Various chips)
 - SoC QCA9558 integrated 3T3R 2.4 GHz Wi-Fi
 - minipcie slot with 3T3R 5 GHz QCA9880-AR1A (unsupported by ath10k!)
 - 5x 10/100/1000 Mbps Ethernet (AR8327N Switch)
 - 10x LEDs, 2x software buttons

For further informwation on the device, visit the wiki:
<https://openwrt.org/toh/tp-link/archer-c7-1750>

Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
target/linux/ath79/base-files/etc/board.d/02_network
target/linux/ath79/dts/qca9558_tplink_archer-c7-v1.dts [new file with mode: 0644]
target/linux/ath79/image/generic-tp-link.mk

index 603251954bc5bc822d8746d41eb5927c7c0254a1..0db7ad4c5cc36b53bc592a218f43fec28fec9f3c 100755 (executable)
@@ -80,6 +80,7 @@ ath79_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "0@eth0" "3:lan:1" "5:lan:2" "4:wan"
                ;;
+       tplink,archer-c7-v1|\
        tplink,archer-c7-v2|\
        tplink,tl-wdr4900-v2)
                ucidef_add_switch "switch0" \
diff --git a/target/linux/ath79/dts/qca9558_tplink_archer-c7-v1.dts b/target/linux/ath79/dts/qca9558_tplink_archer-c7-v1.dts
new file mode 100644 (file)
index 0000000..7228a2f
--- /dev/null
@@ -0,0 +1,46 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca9558_tplink_archer-c7.dtsi"
+
+/ {
+       compatible = "tplink,archer-c7-v1", "qca,qca9558";
+       model = "TP-Link Archer C7 Version 1";
+};
+
+&gpio_keys {
+       rfkill {
+               gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
+               linux,code = <KEY_RFKILL>;
+               linux,input-type = <EV_SW>;
+               debounce-interval = <60>;
+       };
+};
+
+&gpio_leds {
+       wlan5g {
+               label = "tp-link:green:wlan5g";
+               gpios = <&gpio 17 GPIO_ACTIVE_LOW>;
+               default-state = "off";
+               linux,default-trigger = "phy0tpt";
+       };
+};
+
+&mtdparts {
+       uboot: u-boot@0 {
+               reg = <0x000000 0x020000>;
+               read-only;
+       };
+
+       firmware@20000 {
+               reg = <0x020000 0x7d0000>;
+       };
+
+       art: art@7f0000 {
+               reg = <0x7f0000 0x010000>;
+               read-only;
+       };
+};
index 4c85099a1a6fc9e6f318ee1132c105e6683da893..926c3cb6181c7956536e6f515f51a20d2a10de5f 100644 (file)
@@ -1,5 +1,14 @@
 include ./common-tp-link.mk
 
+define Device/tplink_archer-c7-v1
+  $(Device/tplink-8mlzma)
+  ATH_SOC := qca9558
+  DEVICE_TITLE := TP-LINK Archer C7 v1
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport kmod-ath10k ath10k-firmware-qca988x
+  TPLINK_HWID := 0x75000001
+endef
+TARGET_DEVICES += tplink_archer-c7-v1
+
 define Device/tplink_archer-c7-v2
   $(Device/tplink-16mlzma)
   ATH_SOC := qca9558